Compressor not switching on

hi all. i have a weird issue.

my system worked fine when i built it and tested it, and even for the cooling part of my first brew. now it seems that it just cant turn on the compressor.

for the record, i am using THIS SSR.

if it is in normal operation mode, it turns on for a split second and then its like there is a inrush current that is causing a spike and it reboots the arduino. causing it not to cool.

if i turn off the fridge at the wall, and it then fires the relay, and i then switch the fridge back on, it works as it should. so to me that kinda diss-prooves the inductive spike scenario.

and if i change the pin mode from non-inverted to inverted, it fires it up straight away. and works as it should. (just in the reverse mode)

i am kinda stumped by this, both my arduino and odroid have been run from an isolated supply and even off battery to eliminate a spike through their power packs been an issue, and i have tried a few different usb cables.

any ideas?


ok, so an update. i have tried to change it from a ssr to a mechanical relay break out board, and i even changed to a new arduino.

i get 1 cycle on and then off, and from there it is as though there is a spike again. i have even tried to use a relay driver to drive the relay breakout board and still no go.

i then thought to try changing the cooler pin to D4, and it results in the same symptoms.

so i am totaly lost as to what is causing the issue. i feel as though the hardware issue has been eliminated, but am open to ideas

any ideas from the wiser members in the comunity?


That Arduino software has not changed for over a year and has had very little problems. This is definitely a hardware problem. If your Arduino is rebooting, you have a hardware problem.

An SSR will have less inrush current than a mechanical relay, because it switches on a zero crossing. But 3A is a bit low for a fridge I think. At least for the peak current.

I agree

I have looked up the specs on the SSR and it has a 80a peak inrush. To my understanding, that is ample. When it worked once i saw a peak of only 5a through my power mater. Soni don’t think it is an issue. But I will try again with another arduino and perhaps try a little more isolation between the pins and the relay breakout board.


hello all

okay, i have pulled down my arduino controller, and replaced the SSR’s with mechanical relays.

i am using a transistor to drive the relays, and it still flicks off instantly through the brewpi software, i have re-programmed the duino with my own code to turn on and off every minute, and left it going for an hour with perfect results.

the arduino is driven from the same odroid and using the same usb cable as with the brewpi software on the duino.

however, with the brew-pi software on the duino, if i let it kick in the fridge relay, and then i turn the fridge on at the wall, it works as expected.

so i think i have ruled out the hardware issue.

any other suggestions i can look into?


Do you have a reverse current protection diode in parallel with the relay coil?

Is the Arduino switching modes (from cooling to idle)?

Yes I have a diode on the relay coil.

And yes, it switches modes from cooling to heating. As soon asnit tries to kick the compressor on, a split second later it reboots the arduino.

If I change the pin to inverted, it fires up and works constantly and then when it tries to kick in it turns off as it would for a backwards pin. And then fires back up normally.

I have writteny own code on the duino and it cycles properly so ony end I think it has eliminated hardware as the issue. I have tried to run the arduino off a battery and keep it totally isolated from the fridge and still no go.

ok, i have taken my unit over to my friends house and tried it on his fridge. works perfectly.

so that leads me to something in the fridge causing the issue. any ideas as to what? i am thinking some sort of inductive spike or something, but am unsure.