Confused by difference in dates between profile and chart

Hi everyone

I have tried to figure out why setpoint is at 18 when according to profile it should be 17 degrees. Then i realized there is a difference between the date in the chart and in the profile which maybe has something to do with this. I am however a bit confused as to why the date in the chart is what would be used as setpoint. I would have imagined it was the setpoint in the profile (the redline that follows the date).

Well anyway, does any one have a suggestions to how i can change the date in the chart if that is the problem or a suggestion to what else i could do to make the profile work thanks

Check the time on the raspberry pi and the time zone setting (run sudo raspi-config) and check the time on your PC. I think they don’t match.

Hello Elco, thank you for your reply

It turned out that there was a typo in the /etc/network/interfaces file

I typed “dns-nameserver” as written in your installation guide, apparently it should read “dns-nameservers”

added the ‘s’ and now it works!

Thanks, I have updated the guide.


I’ve been battling a similar issue to this and it’s possibly since changing houses or modems (not sure).

The beer profile date and time is correct because when I click “insert now”, the correct date and time is entered. Up in the graph though the date is out by about 5 days and I have absolutely no idea why.

I’ve gone into the interfaces file like the suggestion above, however my interfaces file has different lines in it. I reentered the wifi username and password and that hasn’t fixed the problem. I’ve also checked the internationalisation options. I’ve had this brewpi running for about 7 years and the issue appears to have only just started. It’s a real pain as the beer profile option is not able to be used because of the date difference.

In the image, the beer profile day 0 is now, yet the graph shows the 6th Sept (not 11th)


I think insert uses the time on your PC in the browser and data logging uses the time on the pi.
Check the date on the pi.

Probably can be set with raspi-config.
You posted your WiFi password, might want to remove that.

Ok I think I’ve got it fixed now. Had to manually enter the time and date. Will monitor it to see how it goes. Thanks