Connection issues - Spark 4 and RaspberryPi


I have a problem with my BrewBlox setup. I recently added a Spark 4 to my setup where I have a Spark3 running with an installation of BrewBlox on a RaspberryPi. Once set up, everything runs fine for a while, but within 24 hours, the Spark 4 drops out of BrewBlox (i.e. icon turns red and there is no access through the GUI) and I cannot access the RaspberryPi through SSH. Both Sparks seem to be working fine and controlling what they are set up to do, and both have IP addresses.

The Spark 3 is connected through USB and the Spark 4 through WiFi, the RaspberryPi is connected over the LAN. I have to reboot the RaspberryPi and then everything works fine for 24 hours. I have run the log immediately after restarting the RaspberryPI this morning and the file is at: I ran the update command and the log file after is at:



The Pi shows multiple undervoltage errors. You’ll want to ensure that its power supply is sufficient, and possibly connect an external power supply to the Spark 3 so it doesn’t draw through USB.

Thanks Bob,

The Spark 3 has it’s own power supply, so that is not it. I will try a different power supply for the Pi and see if that sorts it out.

To check whether you’re still getting errors, you can run dmesg on your Pi.

I have run into this same issue. It nake no difference if Spark 3 and 4 are on their own PSs or not. The Spark 4 doesn’t drop out on my at 24 hours but usually every 2 days or so. Log files are small but I have not have the time to download log to filter for errors at the moment. it is fustrating. It happened more when all my stuff was on Spark 3 but now that everything is on Spark 4 not quite as much.

Undervoltage on the Pi can happen even if the Spark has its own power supply, especially when using a phone charger. I’d have to take a look at the logs to rule it out.

That said, undervoltage is far from the only possible cause - it’s just the easiest to diagnose and remedy. Swap memory overflow will also cause the Pi to hang. This can be remedied by either disabling swap memory altogether, or increasing it to 2GB.

RPI 3 B+ freeze when CPU usage is high - Raspberry Pi Forums discusses this.

Troubleshooting | Brewblox for instructions on disabling it. The thread above describes how to increase.

I am having a similar issue with new installation on Raspberry Pi 4 and Spark 4. Spark 4 is connected over wifi and shows up on server but never lasts more than a couple of hours before showing red dot. If I reboot the Spark it fixes the problem momentarily, also the systeminfo shows ip address even when the Spark is correctly connected and has valid ip on the screen. Here is a diagnostic dump if it can help…

To confirm: here it is the Spark that’s having trouble, not the Pi?

In your router’s settings, is the Wifi channel set to a fixed value?

How is Wifi strength at your Spark? You can use a phone to double check.

This issue was solved by providing Spark 4 with its own dedicated power supply. After several power bricks were tried which caused the same issue I added a power brick with 1A capability and issue was resolved quickly and has been reliable for several weeks (Normal power bricks for older phones and evices were 850 ma capability and that caused flaky issues. The trick is to have enough power avialable to drive Spark 4 with GPIO boards attached.