Container name "/brewpi" in use


Probably a noob question. I am going through the set up page on the wiki that uses Docker. I am successfully to the docker run step using the USB connection variation. When I run it, I get:
Docker: Error response from daemon: conflict. The container name “/brewpi” is already in use by container". The error goes on with a long text and number string listing the name in quotes.

What do I need to do to move past this error?

Thank you,



It looks like you already created a container named brewpi.

You can show all your containers with:

docker ps -a

You can remove an existing container with:

docker rm container_name_or_id

So in your case:

docker rm brewpi

You say the error you get is container name /brewpi in use. How did the slash get in that name?


The docker rm brewpi command worked. I had actually tried rm brewpi from my very limited CLI knowledge.

I retyped command and got erro "error gathering device information while adding custom device “/dev/ttyACM0” lstat /dev/ttyACM0: no such file or directory.

My Spark3 is plugged into the Raspberry Pi3 via mini USB. The Spark 3 is powered up and in hardware test mode. Two sensors plugged into spark seem to work fine.

I did find something earlier about needing to do touch calibration. However, when the Spark 3 starts up and asks for you to touch stylus on +, the + symbol blips briefly in top left and lower right corner. I do not seem to be able to calibrate. After about 30 sec, the Spark goes into hardware test mode.

Sorry if these questions are basic.

Thank you,



You can see all connected USB devices by running:

ls /dev/ttyAC*

If there are none, you should try a different USB cable.

Does the Spark go into touch calibration without you touching the screen? Then it is possible that the screws are too tight and the touch screen is pressed by the casing. You could try loosening the screws a bit.


Loosening the screws worked with the spark. They were very tights. It now boots right into hardware test mode.

I ran the ls /dev/ttyAC* and got a "No such file or directory error. I will pick up a new cable later today. My keyboard is plugged into on of the Raspberry Pi ports. Wouldn’t that show up as a connected device?

Is there anything specific I should be looking for on the new cable?

Thank you,



Ordered new cable and arrived today. Ran: ls /dev/ttyAC* command. Result shows /dev/ttyACM0

Ran following command from wiki-

docker run -d --name brewpi -p 80:80 -v ~/brewpi-data:/data -v /etc/timezone:/etc/timezone -v /etc/localtime:/etc/localtime --restart always --device=/dev/ttyACM0:/dev/ttyACM0 brewpi/brewpi-raspbian

Still get error: Error response from daemon: Linux runtime spec devices: error gathering device information while adding custom device “/dev/ttyACM0”: lstat /dev/ttyACM0: no such file or directory.

Again sorry if this is basic, but I cannot find any other resources to help troubleshoot.