Controller Not Running Profile without Server?


#1

Hi All,

I have brewPi spark 3 running the latest firmware and brewpi server also running latest. On two occasions now I have noticed that if i take my laptop (which has the server on it in a docker container) away from my network, that the controller doesn’t continue the profile it’s running. It just maintains the last temperature it was on… I was under the impression that the controller operated completely independently of the server?

For example, I have/had a profile running last week which had my brew sitting at 19c for a week before crashing to 0c over 4 days. During the this time I went away for the weekend and returned 2 days into the cooling period, however the brew was still sitting on 19c and the controller had ‘Beer Set: 19’ displayed on it… ? as soon as my laptop connected to the network, the controller updated and immediately tried to chill the brew to ~8c…

I noticed but hadn’t really paid attention to this same behaviour a little earlier in the same brew as well - at the time i thought i’d just misread something.

Is the controller supposed to continue the profile (if in profile mode) without being connected to the server?

EDIT: incidentally this is the first brew i have done on the latest firmware - I’m fairly sure but not 100% positive that this is not how it worked on the previous firmware i was running (not sure what version that was)


#2

A beer profile has never run on the controller. It’s always been controlled by the script. I’ve had a few times where my controller has lost WiFi and the profile has stopped. I also recently changed a profile and didn’t clicked “apply” and wondered why the profile was showing something different to hat the beer setting was.


#3

oh ok, I thought when you ‘applied’ it, it sent it to the controller and it could run by itself, just obviously not logging it back to the server.
I guess I’ve learned something today :slight_smile:

Cheers.
Mike


#4

Hi,

I can’t find the option to create a new post, possibly because I’m a new user.

I’ve got a similar problem.

I’ve got the software running on a Pi, the problem is the beer setting is not keeping up with the profile.

See the attached photo

I’ve tried applying the profile again and restarting the Pi.

The profile is indicating 21 degrees, and the beer is still set to 18.

Jon


#5

Check the system time on the pi.

We’ll move profiles onto the spark in the new release, so they’ll keep tracking without the server


#6

Did you edit the profile? I found that you have to click “Apply” after modifying a profile


#7

Thanks Elco, it was still set to UTC.