Could not find compatible serial device

Hi everyone,
I’m having trouble flashing my Arduino Uno. This is probably also why the webpage says, the script is not running.
I have BrewPi running on a RaspberryPi and receive the following error when executing

Checking current firmware version... Apr 16 2016 16:16:34 Opening serial port Apr 16 2016 16:16:44 Error while opening serial port: Could not find compatible serial devices Unable to receive version from controller. Is your controller unresponsive and do you wish to try restoring your firmware? [y/N]:

I get a very similar error when trying to reprogramm the Arduino via the BrewPi webpage.

When executing I get the following result:

All ports: /dev/ttyACM0 - Arduino Uno, VID:2a03, PID:0043 /dev/ttyAMA0 - ttyAMA0, VID:None, PID:None Compatible ports: Selected port: (None, None)

However lsusb gives me this:

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. Bus 001 Device 008: ID 2a03:0043

I also tried flashing the ‘minimal’ or ‘blink’ sample to the Arduino via a PC. However it didn’t change anything…
I hope you guys can help me. I’m kind of stuck…

Thanks in advance

Your Arduino seems to have a different VID than a standard Arduino.

Add yours to the list in

Thanks a lot! This works like a charm :grinning:
Now I’m trying to setup my devices but only see one A5 device (actually my probes are on A4) which is not recognized as a OneWire device and I cannot set as a temp sensor.
I suspect my Arduino has for some reason stopped providing 5V over the pin since I flashed the ‘BareMinimum’ sample to it. I have a sainsmart 2 Relais module hooked up to it aswell which used to startup before I flashed the ‘BareMinimum’. If so, this would also explain why the probes don’t work properly… unfortunately i don’t have a multimeter on hand. Any sugestions what to do?

EDIT: I tried DS18X20 Arduino OneWire Sample and both probes are giving me valid data in the serial-monitor (changed the probes to pin 10 for this). So the wireing seems fine. I retried the brewpi script with the probes on pin 10 without success however. It doesn’t even see any device on Pin 10. Only one on A5, where nothing is attached. Btw. it seems to recognized my relays correctly on Pin 5 and 6…

EDIT2: I changed the probes back to A4, but brewpi still refuses to see them. I now borrorwed a multimeter. Everything gets 4.8V, so I guess the relay LEDs only light up when they are switched to on. Also the probes get their 4.8V. I also measured the resistor and it is almost exactly 4.7K Ohm… I really don’t know whats wrong… I’m stuck…

BrewPi only looks for temp sensors on pin A4.
The output pins are pre-defined and not automatically detected. Your relays are not automatically detected.

I am not sure whether DS18B20 sensors work with BrewPi, we only use DS18B20 sensors. It looks like they don’t.

If you want something that works without much trouble, get the BrewPi Spark and some of our more plug and play sensors with RJ11 connectors.

I do not recommend using Arduino with BrewPi. We will not provide software updates for Arduino and the code is 1 year behind our BrewPi Spark code.

I put it back to A4 without success. Also I’m using DS18B20 Probes.

I absolutely understand you recommending the BrewPi Spark and I will most probably get one very soon. However it would be nice geting this to work just for now as I have all the equipment on hand and a 5G batch waiting to ferment in my new fridge :slight_smile:

Thanks a lot anyway for looking into it!

1 Like

I have a similar issue regarding flashing uploading the firmware to my Arduino so posted a pull request on GitHub to add my Arduino VID to the (I have no idea what any of this means by the way!). Hopefully that will do the trick.
I will also be buying a Spark in due course but bought the Arduino Uno before I knew about the move away from Arduino so this is a stop gap!

Thanks for the PR. The PID/VID is a unique product and vendor ID that all USB products have.

Useful to know - I notice that I could not save the locally presumably due to permissions - will I have to update Brewpi when GitHub gets updated?

I’ll include your PR in the next update, so you can just stash the changes during the update.

I´m in exact situation, pin A4 doesnt show the sensors, but I can reach the relays (ports 5 and 6) and the sensors were tested with the sample code (library OneWire).

Even using the legacy branch still not OK. My question: is there a possible to do a manual configuration (directly on files) to recognize the sensors?

Check the topic on homebrewtalk. There are many people having issues, because someone is selling sensors that only support parasitic mode. We don’t support parasitic mode.

It’s make sense! I bought a pre made sensor, I don’t know how they made it. I´ll test the resistance between pins VCC and GND and I think if they are in short circuit the sensor is a parasitic mode. Thank you.