"Detected Devices" cannot be installed



I’m running into some issues getting my brewpi up and running. Using the web interface and programming my arduino UNO with the hex file gets my temperature sensors detected and reading values. When I hit the apply button it shows the config command sent. When I Refresh device list there are still no installed devices and the “device slot” reverts to unassigned. I have tried resetting my EEPROM using an arduino sample code. I have also reprogrammed using the web interface multiple times. Any advice would be much appreciated.

Is the shield necessary and a few other questions?
[Solved] White Screen on Spark

Well, got it figured out. The previous post solved it. Resetting the EEPROM via the below instructions.

To send ‘E’ from a Linux box, install screen:
sudo apt-get install screen

Connect to the serial port:
screen /dev/ttyACM0 57600

Send the command to reset EEPROM:
type ‘E’

Exit screen by typing ctrl a, k


For an easier way to do this, use:

echo -ne 'E\n' > /dev/ttyACM0

We require the EEPROM reset before overwriting EEPROM after a change to the EEPROM format (or a fresh install). This is to ensure that you are not overwriting settings that you have not read off the device and need to be restored.