DHCPCD Not Running

I just returned from a few days away and I tried to see how far along I am fermenting. Tried connecting using a browser and to my surprise it timed out. Checked the connection using the cat5 cable connected to the Raspberry PI by connecting it to my laptop. It works fine. Done some searching and tried this
sudo systemctl enable dhcpcd.service
sudo systemctl daemon-reload
sudo systemctl status dhcpcd status and this is what it looked like…

Still have DHCPCD Not Running

Raspberry Pi 4: DHCPCD route socket overflowed · Issue #4092 · raspberrypi/linux · GitHub suggests editing dhcpcd settings to exclude the virtual network interfaces spawned by docker

Fastest workaround:
sudo nano /etc/dhcpcd.conf
Insert the following line at the end:
denyinterfaces veth*

It exclude the virtual container interfaces from dhcpcd.

I’m also a big fan of disabling IPv6 altogether, but that depends on your preferred network configuration.

echo 'net.ipv6.conf.all.disable_ipv6 = 1' | sudo tee /etc/sysctl.d/90-disable-ipv6.conf
sudo sysctl -p /etc/sysctl.d/90-disable-ipv6.conf

Thanks Bob, I’ll give it a try !!

That worked, able to see my Dashboard !!! Thanks Again !!!

1 Like