Docker aborting :-(


#1

Due to a corrupted SD card I have to reinstall BrewPi. of course, now we have the Docker install as part of the installation and this is not working for me. Docker service (daemon) does not work. If I do a systemctl restart docker, I get a message that there is a core dump. Can anyone help, please.Images of the texts that are generated shown below.


#2

So I tried the solution in another thread of downgrading Docker (to 18.05). Now Docker runs but I have a problem with the pull command

Why is this all so difficult :hot_face::rage:


#3

Hi, is this on a fresh Raspbian install? If so, which pi version?
We are testing with docker on the pi continuously and have not encountered this.

Did you add the pi user to the docker group and reboot afterwards? That can explain the ‘not able to connect to docker socket’ error.

sudo usermod -aG docker pi
sudo reboot

I can try if I run into the same problems if I install docker on a fresh pi of the same HW revision.


#4

Elco, bedankt voor je snelle antwoord.
Unfortunately I did execute the usermod command, twice actually, just to be sure.

I am running on a RPi 2 with a wifi dongle. everything was working OK on the earlier release of Raspbian (wheezy/jessie?) but I had to rebuild due to the SD card corruption. Looks like Docker might help for future cases of corruption.

Stefan


#5

Forgot to mention, latest version of Raspbian, just downloaded the standard (not lite and not recommended software) from the link in the Wiki.

Used Etcher to transfer to a 16GB SD card, I will try a 32GB card
Stefan


#6

I always use lite, but both should work I guess.


#7

Bedankt,
If the 32GB does not work I will try the lite

Stefan


#8

So the full did not work so downloaded the LITE version. Used Etcher to write to my 32GB SD card. started it up, ran raspi-config and then installed docker, added pi to Docker group.
Unfortunately, Docker still aborts with a SEGV error, see pix below


#9

Does this mean there is something wrong with my RPi? If I need to replace it, does BrewPi run on a Zero W?

Stefan


#10

BTW, I checked, not a RPi 2 but a RPi B+. Does that make a difference?

Stefan


#11

Should not I guess.
With the new stack we are targeting only RPi 2 and 3, because many dependencies only support armv7 and not armv6, which the pi 1 is.

I recommend just getting a 3. The speed difference with a v1 is huge.


#12

Elco, Goed nieuws :smiley:

My RPi 3b+ arrived yesterday (thanks Amazon) and I was able to install BrewPi and get it running (thank goodness, I almost cooked my latest brew trying to manually control the temperature - forgot that the heater was on).

Lesson for the community: RPi model 1 does not seem to work with Raspbian Stretch and Docker

Next step, make a backup image of SD card and then try to install the Tilt integration (pending some brave soul creating a better integration using the BrewBlox). After that, start looking for a good way to make an auto backup.

Prettige Kerstdagen
Stefan


#13

One thing I did to bring stability to BrewPi is setup my Pi to boot from USB HD. Used the directions here: https://www.raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/msd.md and used this USB to SATA adapter: https://www.amazon.com/gp/product/B01E7EPKUO/ref=oh_aui_search_asin_title?ie=UTF8&psc=1