Does Spark Core v2 have a max firmware version?


#1

Trying to upgrade firmware from 0.5.2, I get the following message. I’m wondering why the highest version I am offered is 0.5.2, rather than 0.5.10.

Checking current firmware version…
Oct 13 2018 20:55:38 Background thread for serial started
Oct 13 2018 20:55:38 Serial (re)connected for Spark Core with WiFi [6D72067A4957] at port: ttyACM0
Oct 13 2018 20:55:40 Background thread for serial stopped
Current firmware version on controller: 0.5.2

Checking GitHub for available release…

Available releases:

[0] 0.5.2
[1] 0.5.1
[2] 0.5.0
[3] 0.4.4
[4] 0.4.3
[5] 0.4.2
[6] 0.4.1
[7] 0.4.0
[8] 0.2.11
[9] 0.2.10
[10] 0.2.9
[11] 0.2.8
[12] Cancel firmware update