Downloading firmware failed

Here’s the snippet of the output. Looks like the download of the firmware failed.

The update script can automatically check your controller firmware version and program it with the latest release on GitHub, would you like to do this now? [Y/n]:Y
Stopping any running instances of BrewPi to check/update controller…

Checking current firmware version…
Nov 29 2015 21:40:23 Opening serial port
Current firmware version on controller: 0.2.10

Checking GitHub for latest release…
Latest version on GitHub: 0.2.11

Version on GitHub is newer than your current version, downloading new version…
Downloading latest firmware…
Downloading firmware failed

*** Done updating BrewPi! ***

Do you get the same result when you rerun the upgrade script?

Whenever I run the update script it failed the exact same way.

The apt-get works fine but the download doesn’t, it doesn’t make sense. I think I do have enough space. Is there a way to add some verbiage to the error ? I can manually add the verbose if you tell me where to do it (could probably figure that myself but would be faster if you tell me).

I am currently rewriting the update script for the new release (tomorrow). Please hold on.

Sounds good! Looking forward to try it.