Duplicate beer and fridge settings and sensors (SOLVED)


An odd one here, not really causing a problem, but some confusion.

I appear to have multiple duplicate settings entries and sensors. I only have one Spark which has one expansion board attached, which in turn controls one fridge, with one heating and one cooling output.

I have, for a while now, shown multiple options when selecting what to us to drive the fermentation profile, as well as when plotting graphs and selecting what to display. In each case it is the highest number one which I need, but I am just wondering if there is a good way to clean this up?

I only have one beer and fridge sensor shown, but it is named “Ferment Beer Sensor-2” (similar for the fridge).

Thanks for the awesome software!


It looks like you’ve run the quickstart wizard multiple times, and only removed the dashboard.

You’re not the first one with this issue, so we wrote this: https://brewblox.netlify.com/user/removing_things.html

The surplus keys will disappear from your graph options 24h after you removed the source block.

Thank you for the reply.

I currently have a beer in the fermentation fridge. Once this has completed, I will follow the steps on the page for donig a clean start in the section: https://brewblox.netlify.com/user/removing_things.html#reinstall-brewblox-from-scratch



Finally managed to keg my Saison!

I followed the instructions to do a clean install, and this seemed to be working last night. When i can to look at it today, I get an error opening the web page saying: “Failed to access the datastore. (Reload/Dismiss)”

Attempting dismiss leaves me on the page, but no dashboard or spark loads, reload gives me an error page:

"Secure Connection Failed

An error occurred during a connection to . PR_END_OF_FILE_ERROR"

Logs are here: https://termbin.com/e7y6

I have tried rebooting the Pi, but no effect. In the logs, it says “spark-one not found”, not sure if this is talking about the spark box, or this is what datastore connection was failing. The Spark is connected to the Pi by USB is this makes a difference.

Any advise?


In your log, all your services are offline. Did you run brewblox-ctl up after rebooting?

That is odd, I rebooted after generating the logs earlier. So the logs before were from before the reboot. Everything was working last night, so not sure what changed.

I ran brewblox-ctl up just now and everything is working again.

I have never had to run that before, has something changed that requires this now - I know that my Pi had been rebooted periodically before the clean install and just worked everytime!

Anyway, thank you for the quick response (as always!)

Services are set to restart unless stopped. Typically, that means they will restart if you reboot the Pi.

They likely failed to start after your reinstall, and thus did not automatically restart.

Did you close the UI while reinstalling? It may have been an issue there, with the backend suddenly disappearing.

In any case, good to hear it works now. I’ll reinstall our test setup soon, see if it reproduces.

Understood, but it was working after the reinstall. I set the fridge to be on Constant Fridge Temperature at 3C, with one of my lager kegs in there for testing. This is still set, and the Spark was still working to maintain this, even though the web in terface and the docker services were not functioning…

So something caused the services either to stop, or to fail to start after a reboot…?

Either way, it is working now and I will keep an eye on it. If things stop working again, I will let you know and investigate then…