Edge release 2019/08/12

Firmware release date: 2019/08/06

No dramatic new features this week, just a steady stream of iterative improvements.

Edit: Added a troubleshooting page with known issues / frequently asked questions. It includes a section on known issues that will be updated whenever a bug can’t be fixed immediately.


  • Added two oft-requested features to the Step View widget:
    • The Step tooltip in the widget now shows a detailed overview of the changes that would be applied (current => new).
    • In the settings popup, Steps and Step Changes can now be dragged to change their order.
  • Refactored the Graph settings popup.
    • It now uses tabs instead of expansion items.
    • There’s a combined display settings tab. Y-axis and line color settings are placed here, with room for future settings.
    • Added help text clarifying that only fields updated the last 24h are shown, and that this will include renamed or deleted fields.
    • Added help text explaining averaging periods.
  • In the Builder Widget, tweaked the Select tool
    • You can now drag to add more parts to the current selection. (Previously it would clear current selection)
    • Flow is now correctly updated for currently selected parts after dragging them.
  • The UI is now more responsive while calculating flows.
  • Fixed a bug in the Step View widget where it would use the wrong field for PWM/Setpoint Driver setting.
  • When using brewblox-ctl log, blocks from the default spark-one service are added to the output.
    • We’re still working on automatically detecting all active Spark servies.

Relevant links:

1 Like

Tinkering around with BrewBlox for upcoming brew session which I will do with BrewBlox. Have to say the setup works well and the interface looks great! Well done guys, keep it up!

Is there a way to update brewblox-ctl from the web ui? Or am I blind?

No. Nowadays you can update the firmware from the UI, but the brewblox-ctl tool requires command-line access.

It’s a bit of a chicken-and-egg problem, because brewblox-ctl is the one starting and stopping the UI web server.

I just upgraded to the latest release, brewblox-ctl is running on an Ubuntu server 18.04.
After updating, the brewblox-ctl wont start anymore, only getting the following error messages:

Also, when trying to install the latest version with pip I get:

brewblox was working smoothly until the update. Any thoughts how I can fix this?

Kind regards

I’ll have a look. The issue does correspond with some weirdness I saw when I updated dependencies. Apparently I didn’t completely fix them.

Ok, solved it myself in the meantime by adding --force-reinstall to the “pip3 install -U brewblox-ctl” command.
Service is now running again and the UI is accessible.

The UI tells me that spark is running the latest firmware - 06.08.2019. Is that correct?

Yes, that’s the latest. Firmware build date can also be found in the release notes.

Ok, thanks.

  • Fixed a bug in the Step View widget where it would use the wrong field for PWM/Setpoint Driver setting.

Doesn’t seem to be solved yet - PWM setting still remains unchanged even though it is listed as a changed item in the tool tip:

Both pumps remain unchanged regarding their duty setting.

Looks like you’ll have to remove and re-add the field change.

They’re indexed by key, which just changed from setting to desiredSetting. Note it also doesn’t pretty print it anymore as “Duty Setting”.

Edit: Looks like two new issues here:

  • migrating settings, or alerting people to manually change them.
  • pretty print the pump state value instead of showing “1”.

Great, now it works!

Good to hear. I also pushed a fix for the dependency weirdness in brewblox-ctl. Now shouldn’t complain the next time you update.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.