Error Updating to latest

I am trying to update brewblox to the latest. I has been a while, probably June sine I have updated, and when I ran the command I got the following error:

Command "/home/pi/brewblox/.venv/bin/python3 -m pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-a_hq3z0i --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple --extra-index-url https://www.piwheels.org/simple -- poetry>=0.12" failed with error code 1 in None
Command '. .venv/bin/activate && python3 -m pip install setuptools wheel && python3 -m pip install ./brewblox-ctl.tar.gz && python3 -m brewblox_ctl update --update-ctl-done' returned non-zero exit status 1.
Command '/usr/bin/python3 /home/pi/.local/bin/brewblox-ctl update --update-ctl-done' returned non-zero exit status 1.

I tried it again with the same results. Not sure what I need to do at this point to get it to update.

Thanks

What is the output of these commands?

source .venv/bin/activate
alias python3
which python3

If there’s an alias, you should remove it.

Doesn’t look like there is an alias

pi@raspberrypi:~ $ source .venv/bin/activate
-bash: .venv/bin/activate: No such file or directory
(.venv) pi@raspberrypi:~ $ alias python3
-bash: alias: python3: not found
(.venv) pi@raspberrypi:~ $ which python3
/home/pi/brewblox/.venv/bin/python3

That looks correct. Does the error still happen if you remove the .venv dir and retry?

i have the exact same problem, and no i did not solve it with remove .venv dir…

Same here. Removing .venv didn’t fix it. I upgraded pip and I think I broke it even more. I think it may be time to just reinstall from scratch.

The install script from the startup guide (recently updated) is designed to be able to upgrade old installs.

Reconnect SSH first to reset env. If this fails with the same error, it’s more likely to be a software / dependency bug. I will have a look tomorrow to verify.

It was easy enough to get everything reinstalled. Up and running in under an hour. I appreciate the suggestions. Thank you for all your help.

1 Like

The issue was a circular dependency during the pip install. I pushed a fix.

Edit: if you are getting the following error:

  This package requires Rust >=1.41.0.
  ----------------------------------------
  ERROR: Failed building wheel for cryptography

This is due to a temporary build problem on their end. To fix this:

source .venv/bin/activate
pip3 install cryptography==35.0.0

I expect this to be fixed in a matter of hours.