Errors Occur During Setup


I’m trying to do a fresh install onto my spark 3. But the new Install guide doesn’t seem to work for me nd I can’t find the random set of posts I used to install everything last time. I’m stuck at Step 3 when I run the
brewblox-ctl install command I get the following message.

Hit:2 buster InRelease
Hit:3 buster InRelease
Reading package lists… Error!
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: buster InRelease: Splitting up /var/lib/apt/lists/download.docker.com_linux_raspbian_dists_buster_InRelease into data and signature failed
W: Failed to fetch Splitting up /var/lib/apt/lists/download.docker.com_linux_raspbian_dists_buster_InRelease into data and signature failed
W: Some index files failed to download. They have been ignored, or old ones used instead.
E: Clearsigned file ‘/var/lib/apt/lists/download.docker.com_linux_raspbian_dists_buster_InRelease’ contains unexpected line starting with a dash (msg)
E: The package lists or status file could not be parsed or opened.
Command ‘sudo apt update’ returned non-zero exit status 100.

If I try and do any of the other steps it’ll just return the same error message set. have I done something wrong here?


It looks like it downloaded some corrupted file during a package manager update.

You can try removing the cache, and then retrying the install

rm -rf /var/lib/apt/lists/*
sudo apt update

brewblox-ctl install

Thanks Bob! That got the install done. Now I’ve come across a new issue. I can’t flash the spark, when doing that step I get the following error.

pi@raspberrypi:~/brewblox $ brewblox-ctl flash
Please press ENTER when your Spark is connected over USB
INFO Pulling flasher image…
edge: Pulling from brewblox/firmware-flasher
Digest: sha256:0b1982615fb66ae8ae1ae57c3ada331eded14d0e36bdd257f2a966d1d08a7a58
Status: Image is up to date for brewblox/firmware-flasher:edge
INFO Stopping services…
Removing network brewblox_default
WARNING: Network brewblox_default not found.
INFO Flashing Spark…
Triggering dfu on port /dev/ttyACM0
[Error: Error: No such file or directory, cannot open /dev/ttyACM0]
Flashing P1…
Flashing System 1 file…/app/node_modules/particle-cli/node_modules/lodash/inde x.js:2

SyntaxError: Unexpected end of input
at wrapSafe (internal/modules/cjs/loader.js:979:16)
at Module._compile (internal/modules/cjs/loader.js:1027:27)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1092:10)
at Module.load (internal/modules/cjs/loader.js:928:32)
at Function.Module._load (internal/modules/cjs/loader.js:769:14)
at Module.require (internal/modules/cjs/loader.js:952:19)
at require (internal/modules/cjs/helpers.js:88:18)
at Object. (/app/node_modules/particle-cli/dist/lib/has-supported -node.js:3:11)
at Module._compile (internal/modules/cjs/loader.js:1063:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1092:10)
Command ‘docker run -it --rm --privileged -v /dev:/dev brewblox/firmware-flasher :edge flash’ returned non-zero exit status 1.

I’ve tried flashing in safemode, normal the USB cable is capable of data and power and the Spark address is seen as per one of your other posts.

thank you for your assistance

Depending on your version, you may not have to flash the Spark over USB. If I recall correctly, the last update that required a USB flash was about a year ago.

For more recent versions, you can skip the flash, and update the firmware through the UI.

If only the Spark is connected to your Pi, it may be solved by unplugging the USB cable, waiting a bit, and then reconnecting it. USB detection in the flasher is not perfect, and it checks the first/most common address as fallback.

I’ll have a look on this end to check whether anything reproduces.