Eventbus not starting after upgrade

I have just tried to upgrade a very old installation (2020) and after the update it will not start back up again…
I also tried a fresh install with the same result…

Both attempts are running on a virtual proxmox machine (the old on ubuntu and the fresh install on debian)

Creating network “brewblox_default” with the default driver
Creating brewblox_eventbus_1 … error
Creating brewblox_ui_1 …
Creating brewblox_history_1 …
Creating brewblox_spark-one_1 …
Creating brewblox_ui_1 … done
Creating brewblox_history_1 … done
Creating brewblox_spark-one_1 … done
Creating brewblox_redis_1 … done
Creating brewblox_traefik_1 … done
Creating brewblox_victoria_1 … done

ERROR: for eventbus Cannot create container for service eventbus: invalid mount config for type “bind”: bind source path does not exist: /home/bjorn/brewblox/mosquitto
ERROR: Encountered errors while bringing up the project.
Command ‘docker-compose up -d’ returned non-zero exit status 1.
Command ‘python3 -m brewblox_ctl update --update-ctl-done’ returned non-zero exit status 1.
bjorn@brewblox:~/brewblox$ ^C

any suggestions?

A small correction… A clean installation works but when i used my backup the "eventbus_1 fails…

If you manually create the directory with mkdir -p mosquitto, and restart brewblox, does it then work?

OMG… I did not think it could be that simple… But Yes it works now.

Thanks for the help

1 Like