Failed Spark3 flashing

Tried to flash a Spark3 and now the blue led is blinking and nothing seems to help. What to do?

That happens if the spark needs a bootloader update, and can’t download it over wifi.

To fix, connect it over usb, and run brewblox-ctl particle -c bootloader

I’ve tried it maybe 10 times does not help.

Does it show any errors during either the flash, or the bootloader flash?

Does it still show six squares on screen?

If you run brewblox-ctl discover-spark, does it show up?

Had to do a brewblox-ctl flash after and that did it!

1 Like

Bob, I’m running into a similar problem. I did a brewblox-ctl update followed by a brewblox-ctl flash on my v3. I received flash success messages, but am stuck at the blinking blue light. I can see my Spark with brewblox-ctl discover-spark, but when I run brewblox-ctl particle -c flash-bootloader, I’m getting the following:
INFO Starting Particle image…
INFO Type ‘exit’ and press enter to exit the shell
edge: Pulling from brewblox/firmware-flasher
Digest: sha256:f568daf84c6541f13342754c377e99bd4b3bd376b6ad7e68ef8dcd6347b1904e
Status: Image is up to date for brewblox/firmware-flasher:edge
Flashing P1 bootloader…
:::: NOTICE:
:::: Your first flash may take up to 10m to complete - during
:::: this time, your device may regularly change LED states
:::: as Device OS upgrades are applied.
Error writing firmware: Timed out waiting for initial response from device
Command ‘docker run -it --rm --privileged -v /dev:/dev --pull always brewblox/firmware-flasher:edge flash-bootloader’ returned non-zero exit status 1.

Any advice? Thanks.

Are your services stopped/down?
Have you tried it with a different USB cable?

I’d run brewblox-ctl up and didn’t receive any error messages. I’ve not tried swapping the USB cable (which as far as I know was working ok with the previous installation) but can try swapping it. Any recommended sequence of shutdown/restart for the Pi and Spark?

I did have an eventbus error initially on the update, but manually created a mosquitto folder based on a recommendation in an earlier post that made that error go away.

Ah, to clarify: your services should be stopped during a USB flash / bootloader flash, to prevent mixed communication over USB.

You can safely unplug the USB cable between the Pi and the Spark without running any prior commands.

Swapping the USB seemed to do the trick. Thanks for the quick help.

1 Like