Failed Upgrade, System Down

I tried to upgrade this afternoon and ran into an issue where the update fails with an error. The UI loads but nothing works. Everything on the Spark seems to have gotten renamed to “New___”


pi@brewblox:~/brewblox $ brewblox-ctl update
Do you want to remove old docker images to free disk space? [Y/n]: n
INFO Updating brewblox-ctl…
INFO Updating brewblox-ctl libs…
edge: Pulling from brewblox/brewblox-ctl-lib
Digest: sha256:eefc7b1534c8f3b7e76c17e9bef85167ace8495456a310846d0e5ba37b6d8c43
Status: Image is up to date for brewblox/brewblox-ctl-lib:edge
INFO Checking Avahi config…
INFO Stopping services…
Stopping brewblox_history_1 … done
Stopping brewblox_traefik_1 … done
Stopping brewblox_redis_1 … done
Stopping brewblox_influx_1 … done
Stopping brewblox_eventbus_1 … done
Stopping brewblox_ui_1 … done
Stopping brewblox_tilt_1 … done
Stopping brewblox_fermenter1_1 … done
Removing brewblox_history_1 … done
Removing brewblox_traefik_1 … done
Removing brewblox_redis_1 … done
Removing brewblox_influx_1 … done
Removing brewblox_eventbus_1 … done
Removing brewblox_ui_1 … done
Removing brewblox_tilt_1 … done
Removing brewblox_fermenter1_1 … done
Removing network brewblox_default
INFO Migrating configuration files…
INFO Removing depends_on fields from docker-compose.yml…
INFO Creating redis/ dir…
INFO Checking .env variables…
INFO Pulling docker images…
Pulling eventbus … done
Pulling traefik … done
Pulling history … done
Pulling influx … done
Pulling fermenter1 … done
Pulling tilt … done
Pulling ui … done
Pulling redis … done
INFO Starting services…
Creating network “brewblox_default” with the default driver
Creating brewblox_ui_1 … done
Creating brewblox_history_1 … done
Creating brewblox_traefik_1 … done
Creating brewblox_tilt_1 … done
Creating brewblox_eventbus_1 … done
Creating brewblox_influx_1 … done
Creating brewblox_redis_1 … done
Creating brewblox_fermenter1_1 … done
INFO Migrating service configuration…
Connecting https://localhost:443/history/history/ping, attempt 1/60
Connecting https://localhost:443/history/history/ping, attempt 2/60
Connecting https://localhost:443/history/history/ping, attempt 3/60
INFO Migrating datastore from CouchDB to Redis…
INFO Starting a temporary CouchDB container on port 5984…
Connecting http://localhost:5984, attempt 1/60
Connecting http://localhost:5984, attempt 2/60
Connecting http://localhost:5984, attempt 3/60
Connecting http://localhost:5984, attempt 4/60
Connecting http://localhost:5984, attempt 5/60
Connecting http://localhost:5984, attempt 6/60
Connecting http://localhost:5984, attempt 7/60
Connecting https://localhost:443/history/datastore/ping, attempt 1/60
500 Server Error: Internal Server Error for url: https://localhost:443/history/datastore/mset
Command ‘/usr/bin/python3 /home/pi/.local/bin/brewblox-ctl update --update-ctl-done --no-prune’ returned non-zero exit status 1.


brewblox-logs (1).json (572 Bytes)

There is some obsolete configuration in your docker-compose.yml file.

You can remove this: (was used by tilt service, no longer required)

    image: arm32v6/rabbitmq:alpine
    - 5672:5672
    restart: unless-stopped

And remove this line from tilt service config:

    command: -p 5001 --eventbus-host=

Then retry the update.

Thanks, that looks like it worked. It seems though that I’ve lost the Fahrenheit versions of all my temps. The layouts are all showing in C, my Metrics widget shows the triangle on the F values but when I choose C instead they work. And looks like all my history data stopped recording in F. Any suggestions?

Edit: Nevermind, just had to change the UI units setting back to F.

1 Like

Just use Celsius… Welcome to the 21st Century! :rofl: