Flash failed - spark v2

Brewblox popup asked to flash so I did. It failed and spark unit has white screen now with fast flashing blue light on bottom. I also tried the command line. Here are both errors…
Any ideas?
RD Harles

To fix the CLI error, run

sudo apt update && sudo apt upgrade -y

Then retry the flash.

If afterwards it still has a flashing blue light, you most likely updated from a version with an older bootloader.
To fix this, run

brewblox-ctl particle -c flash-bootloader

Edit: fixed command

No upgrade and same error it seems.

Weird. Maybe groovy uses a slightly outdated version of Docker.
What’s the output of docker version?

In the meantime, you can get the same result by running

docker pull brewblox/firmware-flasher:edge
docker run -it --rm --privileged -v /dev:/dev brewblox/firmware-flasher:edge flash

Edit: apparently I’m not overly sharp. Make sure to stop services before you flash.
Same goes for the bootloader command:

docker run -it --rm --privileged -v /dev:/dev brewblox/firmware-flasher:edge flash-bootloader

OK, those 2 commands worked without error but at the end of the flash it said to run this again as you stated earlier:
ONLY If your Spark LED keeps blinking blue, run: ‘brewblox-ctl particle -c flash-bootloader’

Did that and it failed. Still white screen with flashing blue light.

It’s the same for the bootloader command: I posted the command without the --pull argument above.

That seemed to work! Spark seem to be alive again.

Does this appear correct?

Looks good from here. If you can also access the spark in the UI, then everything is up and running again.

How did you install docker btw? Did it get installed by brewblox, or manually?

Docker must have gotten installed with brewblox, I didn’t do it manually.

Tried accessing spark through UI and things seemed to have gotten scrambled.
I’m only using this for a simple fermentation fridge and used the wizard to set it up.

Screenshot from 2021-06-24 17-13-35

EDIT: I just clicked on all of them and they all went away? Guess I need to test system cold and hot to see if it’s working properly??

Are the blocks still present and named correctly? If so, then using the autofixes proposed by the temp control assistant may fix the issues.

OK, yup, I clicked on them all and my fridge started up on 100% cold so something is working.
I’ll will test with water tomorrow.
Thanks for the help!

1 Like

Sorry, one more thing. I just noticed every time I load the UI now I get this error:

If force reloading the UI (ctrl-F5) doesn’t resolve that, check whether docker-compose pull ui gets a new version. If so, best to run brewblox-ctl update.

ctrl-F5 did not fix it.
Also tried docker-compose pull ui
I had run brewblox-ctl update earlier today
Still gives me “Unknown dashboard: dashboard-home” on each reload.

Could you run brewblox-ctl log? The UI error is caused by the UI running an outdated version.
To confirm, the pull said that everything was up to date? Pulling a new image does not automatically stop the old (running) image.

Screenshot from 2021-06-24 18-02-20

Doesn’t really say anything…?

Screenshot from 2021-06-24 18-05-40



It all looks fine. The home dashboard should exist? I only see the fermentation dashboard in your earlier screenshot.

Home dashboard gives error but fermentation page is there…I don’t even know what’s supposed to be on the home dashboard, just saw the error and assumed there was a problem?