Flashing Brewpispark 3 Error

Hi. I am upgrading to brewblox using a raspeberry pi B3+ and a Brewpi Spark 3. I have followed installation steps 1 - 5. However, when attempting to flash my Brewpi, i get the following message:

INFO Flashing Spark…

Triggering dfu on port /dev/ttyACM0
[Error: Error: No such file or directory, cannot open /dev/ttyACM0]
No compatible USB devices found

My brewpi is connected via USB to the raspberry pi and I have tried several USB cables without success.

Additional information (I have no idea if this is relevant): I have to wifi networks. My raspberry pi is working on the new network. The brewpi was previously configured to the old network.
When I connect the the raspberry pi to the brewpi, the brewpi screen shows the brewpi IP nr.
If i disconnect the the brewpi wifi network, I get: USB however the flash wont work.

I have been struggling for some days now. Any help will be deeply appreciated :slight_smile:

No compatible USB devices found.txt (1.1 KB)

To verify USB, could you please run


The Spark 3 should appear as a device with PID:VID 2b04:c008.

https://brewblox.netlify.app/user/troubleshooting.html#frequently-asked-questions shows more detailed expected output.

If the problem persists when lsusb can see the device, we found that it helps putting the device in safe mode first: https://docs.particle.io/tutorials/device-os/led/photon/#safe-mode

Thank you for your quick reply
I ran lsusb, I can’t seem to find the spark.
I have however tried 3 different usb cables, could all of them be bad?.. :grimacing:
Here are the results:

pi@raspberrypi:~ $ lsusb
Bus 001 Device 004: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Technically it’s possible for three cables to be bad or data-only, but I would also check with different USB ports on the Pi.

Sorry for the dum question, but did you mean charge only?

Ah, that was indeed a typo.

Hello. I have the same issue. I have tried 4 cables and all 4 USB ports on my Raspberry Pi 4. lsub shows only:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I am using a brand new Spark 3 and RP 4 which just arrived a week ago.

I am powering the spark via this USB by the way, and the Spark turns on with etc 6 empty boxes. The blue light is flashing.

Can someone please help with some troubleshooting ideas.


You can use other (micro-)usb devices to verify your cables / Pi.
If you plug in a keyboard, and it shows up in lsusb, then the port is probably fine.
If you connect a phone using the micro-usb cable, and it shows up in lsusb, then the cable is probably fine.

If that’s the case, and the Spark still doesn’t connect, could you please open the Spark casing, and take some pictures of its USB connector?

We program them using usb before they ship, so a broken usb port on the spark is unlikely.

Hi. In my case the problem was the type of micro USB cable. All of them where charge only cables I had lying around the house. I went to the store and bought a data cable and voila! Everything worked as it should and has been working perfectly since.

1 Like

Thanks all. I bought a data cable and it worked. I think the lesson here is that most random cables you find around the house are probably power only.

1 Like