Frustrated - Brewpi container will not run


#1

I’ve tried to remove and re-add the brewpi container numerous times. It seems it is having problems with port 80??? Please help


What did I get myself into?
#2

Did you install apache on the Rasperry Pi before you installed docker?

It is complaining because address 80 is already in use by apache, so you cannot bind the docker container to that port.

Your options are to uninstall apache from the host, or to use a different port for the container.

Removing apache on the pi:

sudo apt-get purge apache2

To use a different port, instead of --port 80:80, use --port 85:80 for example. But you will have to point your browser to http://raspberrypi.local:85 in that case. I think you’ll probably want to remove apache from the pi instead.


#3

Hi Elco - I removed apache and all is good now except I need some advice on tweaking the settings for temperature fluctuations.