Full Screen Brewblox UI on iPad

Is it possible to have the Brewblox UI available as a full screen app on the ipad? By including in the head.

<meta name=“apple-mobile-web-app-capable” content=“yes”>

Thanks for looking up the solution as well=) It seems like it has no undesired side effects, so I’ll add it to the UI.

1 Like

I think Android Chrome has a similar tag just without the “apple” reference.
<meta name=“mobile-web-app-capable” content=“yes”>
Would be nice to have the same option on Android as well.

Can do. I must note that apart from the convenience of having a home page link, our UI is not terribly suited for PWA use. It absolutely requires an active connection to the backend: if the service is unreachable, then no amount of local caching is going to make it functional.

1 Like

Great thanks. It’s not purely for the home page link, it should remove the browser address bar and be full screen. The address bar is doing my head in and there doesn’t appear to be another way to remove it.

My intentions were the same as @mbwatty. Just want to get rid of that address bar. I’ve been using the Fully Kiosk Browser on Android,
running the screen in kiosk mode, but it’s a less than ideal solution for my use.

Makes sense. I’ll make an issue for that, and see whether the proposed meta tags fully satisfy.

Just updated but not seeing this full screen, is there a setting I need to enable somewhere?

You should be able to add the UI to your home screen. If you load it from there, it will be without the address bar.

How odd, doesn’t seem to work here, tried deleting the existing link then re-adding via the add to home screen link but still get the address bar.

I’ll have another look then. No hard guarantees it’s fixed immediately: I don’t have an iPhone at hand to test.

That’s ok, have joined the discord so can troubleshoot there if that’s easier?


That may be useful. I’ve done some further reading, and the spec for what is and isn’t possible is inconsistent at best.

Just drop me a message if you have some time =)

Done some troubleshooting with Bob (thanks!)
Was just a caching issue where I needed to clear the cache on my device.

If you go on the phone to
settings → safari → advanced → website data
Then you can clear the cache.

I rebooted my device and works perfectly.