GPIO voltage change errors and overvoltage errors

I just started setting up my system, so my problem may be a trivial thing.
First of all, I have updated everything yesterday, but I keep getting “ERROR: Overvoltage” on all 3 GPIOs. I have set the 24V power supply down to 23.5V just to be sure, but I still get the same error.

I first installed the system with two GPIOs more than half a year ago, but since my brewery build has been delayed, I have only got to test the system during this weekend. The GPIOs seems to be working fine, but the overvoltage error comes back after a little wait. This is the same for all GPIOs.

On the last GPIO that I installed lately, I’m not able to change to external voltage. It does work with 5V, but I really would like this module to run 24V. This error then shows up: " Failed to patch New|OneWireGpioModule-5: {“error”:“CommandTimeout(BLOCK_WRITE)”} "

I am currently testing the system to turn valves and PWM for heating, and that seems to be working well.
Any input on what I could do with the errors Im getting?

Have you connected the power supply to one, or all GPIO modules? You only need one - the others will automatically share when set to use external power.

Thank you for the quick answer. Yes, its connected only to the first GPIO. I have not tried to change it to any of the other ones.

If you measure voltage at power supply input, does this match the 23.5V?

It looks like your controller saw a reboot around the time of the write error. If this was not you restarting or powering down the controller, could you please generate a coredump? To do this:

  • Connect the Spark over USB
  • Run brewblox-ctl coredump
  • Share the result termbin URL here

The voltage was fine, also at the outputs its the same.

Connecting the Spark 4 to a USB fixed all the problems! Then I do not get overvoltage error and I am able to switch power source on all GPIOs.
However, when I disconnect the USB the same “overvoltage errors” are back. I have tested it with three 24V power supplies It acts the same for all. Does the Spark 4 also need power through the USB-port to function properly?

Update: Now Im only getting the overvoltage after start-up (without USB connection). If I soft-reboot the controller the GPIOs with 24V will have the error. If the errors are cleared they do do not seem to reappear until the next controller restart.

We looked into this issue. As far as we can tell, the overvoltage warning is a temporary blip on startup. The next release includes automatic error recovery that will also take care of this issue.

Until then, I’d suggest keeping USB connected to a power source.

1 Like

Thank you for helping Bob,
I probably would not have thought about connecting the USB to the Spark myself. My next test would have been to restack the GPIOs, or lower the voltage more. So you saved me several hours of testing. :grinning:

I suspect that the 24V is available to the output driver quicker than the logic supply and that therefore its reference has not reached the correct value yet. With USB connected, it already has a supply voltage before the 24V is plugged in.

I will have to measure and investigate it a bit. I suspect that this is a startup glitch that can be safely ignored.

Correction. It is an init order bug, not a hardware problem.

The fault is cleared in the same command that raises the overvoltage threshold is from 21V to 33V. In some cases, I think this config was sent too early and the fault was not automatically cleared later.

The overvoltage error is just a flag though and the device resumes normal operation when the overvoltage condition is resolved, even when the flag is still active.

I have fixed this and it will be in the next release, which will be soon.

1 Like