Help. I want connection by USB, not by Wifi

First of all, apologize for my level of English, I am from Spain and I use the google translator.

I have a problem with the Brewblox and the SPARK.

This morning I had the SPARK connected to the Raspberry via USB, because with the Wi-Fi connection I had many problems.
When I logged into Brewblox, the connection would dial via USB.

Today the power has gone out, and it no longer connects via USB.
The Brewblox tells me that it is connected by Wifi, but I don’t want it, I want it to be connected by USB.

I connect and disconnect the USB cable between the Spark and the Raspberry, but it always connects via Wifi.

Can I configure the system to only connect via USB? I don’t want it to connect via Wifi.


To only check USB, you can use the --discovery=usb setting.

To set this for the spark-one service:

brewblox-ctl add-spark --force --name spark-one --discovery usb
1 Like

Thanks for the help.
Where it says “name spark one”, what should I put?
Do I have to look for the name somewhere?

Thanks for the help.
Where it says “name spark one”, what should I put?
Do I have to look for the name somewhere?

It’s the name of your Spark service. You can find it in the sidebar in the UI. spark-one is the default.

In agreement.
Tomorrow I will try it.
But what happens is strange.
Why not connect via USB with the cable connected?
This morning it was connected by Usb, but the power has gone out, and then it no longer connects by

To “see” usb devices, the service must be started after usb is connected. I assume that when the power came back, the spark service started before the Pi saw the usb device.

The service couldn’t see usb, but could see wifi, so it used wifi.

With the --discovery=usb setting, the service restarts automatically if it can’t see usb to prevent this problem.

I’ve tried many ways to get it to connect via USB.
In the brewblox, I have restarted the service, I have restarted the device, I have unplugged the Spark, I have disconnected the raspberry …
and all the time it connects by Wifi, even being connected by Usb.

Tomorrow morning I’ll try the command

If it still doesn’t work, try with a different usb cable.

Also please run brewblox-ctl log

I wanted the same. Only USB connection.
I never configured the SPARK’s WiFi settings, so there is no way for it to connect to the WiFi.
It never has.
It always uses USB.

I never ran that command.

--dicovery=usb as part of the command configured in docker-compose.yml will result in only searching for compatible usb devices.
The default is to look on usb and WiFi. If the Spark has no WiFi, it will end up only finding the usb device.

Holding the setup button for 10 seconds will wipe WiFi credentials. This does mean that the system layer cannot be downloaded from the cloud, so firmware has to be updated with brewblox-ctl flash.

Hello! With the command discovery = usb I have been able to connect the USB to the Spark without problems.
Thank you very much for the help!

As I always tell you, the Brewblox would be perfect if it could be used from a different location through a mobile device.