Help! No comms between Pi and Spark


#1

I purchased a BrewPi Spark V2 in Aug '16. Set up the Pi and Spark - everything working great! However, I now have no communication between the Pi and Spark. When I run the command "ls /dev/ttyA*" the only thing that comes up is /dev/tty/AMA0 (not seeing AMC0 or AMC1). If I run "ls /dev/tty*", I don't get ttyUSB0 or ttyUSB1 either.

So, something is wrong and I'm not sure what. I've replaced the USB cable and ensured it is fitting properly at both ends. I've also run a separate power supply to the Spark as well. The Spark has retained its last settings of Constant Fridge Mode and is holding temp just fine. I just can't communicate with it.

Any suggestions?


#2

Despite that you have replaced the USB cable, I still suspect the cable or the connector.
The connector on the Photon is crap. A bit of yanking on the cable can damage it.

If the connector is broken, the only fix is replacing the photon. If it doesn't look broken, it could be the cable.

It is also worth checking whether it shows up as a serial port on a PC.


#3

I switched out the USB cable and it works OK now. You're right, however, the USB connector on the Photon is really poor.

Thanks for your help!


#4

Good to hear! Yes, I know about the shitty connector. We're switching to a much better USB port on the Spark V3. Because we switched to the P1 instead of the Photon, we could choose our own connector this time and picked the sturdiest one available.