Hitting HERMS mash strike temp taking too long

Using BrewBlox to control HERMS with gas burners. During pre-heat of the mash liquor, I can never hit my strike temp (within a reasonable time). With the burner at 100% heat, the system will raise temp steadily till within 2-3 of target. Then the software starts calling for less heat (to prevent overshoot I presume) such that it would take another 2-3 hours to reach target temp for the strike water.

For example, on the most recent brew with a target strike temp of 72C, heating started at 5AM with the following results:
5 AM = 5C
7 AM = 69C
8AM = 71C

From 5 AM - 7 AM, brewblox called for 100% heat. Then it started reducing heat % such that I think it would take another 2 hours to hit 72C. I am currently telling brewblox to control the temp of the MT.

Are there any configuration adjustments I can look at to better hit target strike temp of mash water?

The D portion of the PID is in charge of reducing power on the approach to prevent overshoot. This is controlled by the TD setting.

If this is too aggressive, you can reduce it or even disable it altogether.

Maybe a higher Kp is needed too. But without seeing a chart and knowing your current settings, we can’t tell you much.

Share the internal chart of the PID block and your PID settings.

How do I “share the internal chart of the PID block”?

I’m running the standard HERMS setup (created by the new process wizard). There is an HLT PID and a MT PID.

Go to the PID block on the dashboard or service page. In its actions menu (widget toolbar), you can open its dedicated graph.

image

That button on the right slides it out. You are not the only one that missed it, so we need to change the design.

HLT PID
Kp 50/C
Ti 10m
Td 10s
I 0

MT PID
Kp 0.69/C
Ti 5m
Td 10m
I 0

Please post a screenshot of the chart, zoomed in on the relevant time period. Your settings seem normal.

Perhaps try with Td at zero for the MT PID. If it causes setpoint swings, it can prevent the integrator from increasing to correct the steady-state error.

Screenshots of graphs and settings for both PID blocks.




Update: I failed to read in detail Elco’s last post (set Td =0 on MT PID) but from Bob_Steer’s suggestion, I reduced Td on MT PID by 1/2 (from “10m” :arrow_right: “5m”). The result was about the same. In the graph below, MT target was 72C but it slows down too much once it get’s close.
I think next brew day I will drop Td to 0 and see what happens.
@Elco You mentioned possibly increasing Kp. Would that also be on the MT PID? Can you suggest an amount to adjust by?

I brewed again on 12 Mar with MT Td = 0 and I was able to hit the target strike temp!





1 Like

Great. Perhaps a small bit of Td will help with overshoot.

You should also have a pump stirring the HLT. That really helps with the temperature exchange. Otherwise, you get standstill colder water around the coil and not much heat transfer.

Yes, I have a pump whirlpooling the HLT water.

In Apr, I forgot to make any changes so brewed with the same settings from Mar. I don’t recall any significant differences. Tomorrow I am going to add a small bit of Td (30s I think) and double the Kp (2x.69 = 1.38) , both on MT PID. Will post back with new results.

Also, one note for posterity sake, the starting settings were the defaults from BrewBlox (as of the current version at that time).

Using the settings above, I hit the target MT strike temp (53.6C) in 2.5 hours! These seem like good settings. I will try these again in June.
Note: 53.6C is lower than normal strike temps, which usually tend to be around 66C. Will see what future tests show.

It may also be helpful to note that in all these graphs, RX temp is the temp of liquid exiting the HERMS coil, while MT temp is the temp of liquid exiting the mash tun.