How to set On/Off Digital Actuators?

Hi all,

Got my fermentation chambers and glycol chest freezer going. What am I doing wrong with my settings? The beer is going up 4 degrees then down 4 degrees. I’d like a more consistent beer temperature. That said, I’d like the digital actuators to be 100% or 0%. Nothing in between. Any assistance is appreciated.

Digital actuators can only be 1 (ON) or 0 (OFF). If you’re viewing longer periods on your graph (>3h), you are shown averaged values.

That said: your fermentation chamber could indeed use some tuning.
This is the glycol-controlled one? Could you please post its current settings? (A screenshot of the PID settings is fine).

Does your chamber have a heater? Could you please post its settings + graph?

Thanks for the reply, Bob.
My setup is a chest freezer that holds about 20 gallons of water and glycol. It’s controlled by the pid. Two submerged pumps are controlled by the other pids for each fermenter. No heater.

What are the constraints on the cool actuator?
What is the period of the cool PWM?

I think this might be a bug in the PWM calculation that I will fix this week. Currently working on it.

The gist is that it sees a short ON time in the past, followed by a long OFF time, which on average is still above the currently desired value, so it doesn’t turn on yet. The fix is to limit how far it looks back.

What will help directly is to reduce the minimum ON time set on the cool actuator.
Set the PWM period to 10 minutes, and the minimum ON time to 5s.

Hi Elco,

The Chill Actuator Settings:

PWM Settings:

I just don’t want to blow up my chest freezer compressor.

Appreciate the assistance.


Perhaps it is easier if you export all blocks and share the json file.

But from just these 2 screenshots, you have a pwm period of only 4 second, and a minimum off time of over 15 minutes. That cannot possibly work.

For the compressor, you need a much longer pwm period, like 1h or 40min, and a minimum off time of 5 5m.

brewblox-blocks-spark-one.json (18.1 KB)

Thanks for the advice. I think I was misunderstanding some of the settings.

I see multiple strange things:

  • Why did you add a delayedOn constraint on Ferm 2 chill?
  • Min Off time on Glycol chill is very large
  • All PWMs have a very short period of 4s, which doesn’t make sense. Especially in combination with minimum ON/OFF times that are larger than the period. 4s is only used for heaters that don’t have constraints in our wizards.

Did you set this up using our glycol wizard? Perhaps erasing all blocks and starting from scratch by running the appropriate wizards again makes more sense at this point.

It’s very late here, so good night!

Hi Elco,

  1. I was having my glycol pump turn on for 1 sec and turn off. I thought that might keep that from happening.
  2. The Glycol off time was set to keep the compressor from turning on too frequently. Perhaps another setting is solving that problem?
  3. PWM’s period. I guess I misunderstood the term “period” and what it controls.
  4. I started with the glycol wizard, but, it renamed all my controls and was confusing me a bit. I saw what it did and attempted to build it myself with my naming structure.

Cheers, Elco!

Start with the correct period for the PWM.

The constraints are only for protection in edge cases. The PWM module is smart and allowed to adapt its period if needed, within limits. If it has a period of 10 minutes, and its target has a minimum ON time of 1 minute, then it will lengthen the period to 20m if it needs to run at 5%.

But if you ask for impossible things, like a minimal 20m OFF period in a 4s PWM cycle, then it will not behave correctly.

The wizards let you assign custom names, but the fields to do so are collapsed by default in the wizard. You’ll have to expand them.

I think I’m confused by the actual definition of the term “period”. I might be approaching it wrong.

PWM: pulse width modulation.
With a period of 10 minutes, and a setting of 30%, the actuator will be ON for 3 min, OFF for 7, repeat.

1 Like

Got it! Thanks!

I reworked my PWD settings. Hopefully, this will be smoother!

brewblox-blocks-spark-one (1).json (17.7 KB)

Keep up the good work!


The graph is looking much better!

1 Like