Impending Brewmergency - Wifi not detected after Docker Install


#1

In advance of an upcoming Brew Day next weekend I decided to completely wipe my brewpi setup since I have not done a single update in a few years. Smart right?

Well…

Right after I installed Docker my wifi interface dropped and it refuses to come back! I see the usb dongle when I run a lsusb. My interfaces file was blank, so I rebuilt it as I thought it should be. I have tried both DHCP and Static Addresses.

When I hover over the wifi icon in the upper right of the screen I get a message “Connection to dhcpcp lost” when I click on it, I receive “No Wireless Interfaces Found”.

Linux is not my forte, but I follow instructions really well. Any help to get this moving along so I can be up and running for this weekend would be super awesome!

Happy to post any files or outputs.

Here is the current content of the interface file just in case it is something simple. I also read about trying to ignore the docker stuff by editing /etc/NetworkManager/NetworkManager.conf but that does not seem to exist in raspbian. Here is that thread https://askubuntu.com/questions/874226/docker-engine-installs-makes-wifi-undetected

source-directory /etc/network/interfaces.d

auto wlan0
allow-hutplug wlan0
address 192.168.0.99
netmask 255.255.255.0
gateway 192.168.0.1
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Thank you all in advance…I can’t imagine having to try to ferment without my BrewPi!!!

-Russ


#2

Nevermind! Disaster averted. I just started over and it worked fine this time. I think that there was an error with my original package update as I had a weak wifi signal from my garage. I moved the Pi inside from the beginning this time and now that all is set up I will bring it back out and connect it to the spark.