Install issues Brewblox - Docker sub-process /usr/bin/dpkg returned an error code (1)


I am doing a totally fresh install of Brewblox as in formatted sd card and raspbian lite install through noobs. I am enabling SSH and setting a static IP address of I am not touching any other settings. I keep getting the installation failing

Executing docker install script, commit: 6bf300318ebaab958c4adc341a8c7bb9f3a54a1a

  • sudo -E sh -c apt-get update -qq >/dev/null
  • sudo -E sh -c apt-get install -y -qq apt-transport-https ca-certificates curl >/dev/null
  • sudo -E sh -c curl -fsSL “” | apt-key add -qq - >/dev/null
    Warning: apt-key output should not be parsed (stdout is not a terminal)
  • sudo -E sh -c echo “deb [arch=armhf] buster stable” > /etc/apt/sources.list.d/docker.list
  • sudo -E sh -c apt-get update -qq >/dev/null
  • [ -n ]
  • sudo -E sh -c apt-get install -y -qq --no-install-recommends docker-ce >/dev/null
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Command ‘curl -sL | sh’ returned non-zero exit status 100.

I found an article online -

The only thing that seems to get me past this is doing the following


sudo apt remove --purge docker* sudo apt autoclean sudo apt autoremove


sudo rm -rf /usr/lib/docker


sudo rm -rf /etc/docker.service.d

Then doing a new install of brewblox with the brewblox-ctl install command

The install works fine and also flashing of the Spark 3. However when I come to getting the wifi active I get issues

? Should I scan for nearby Wi-Fi networks? No
! Something went wrong: Serial port closed early
Error configuring Wi-Fi: Serial port closed early
Command ‘docker run -it --rm --privileged brewblox/firmware-flasher:rpi-edge wifi’ returned non-zero exit status 1.

I sorted this by not trying to do this part over SSH and on the Pi directly so all looks good.

I have a static IP of on the raspberry pi and the Wifi flash has given the controller an IP of

Please Help are the issues I am facing with the docker install corrupting the installation???

couple more things to add that I don’t think are relevant but maybe. The Pi is connected on a ethernet via a Ethernet over power adapter back to my main switch. The Spark controller is connected to this same TPLink device via Wifi. The pi has the static IP and the controller has got something from DHCP during the flash it appears.

This has worked once for me on this exact setup but I did some tinkering with PIVPN and decided to go fresh again and ever since I have not got it working again.

Where possible I like to keep things cabled do I have to use Wifi on the spark 3 or can i just do the process of flashing the brewblox again and miss the wifi setup bit - then just use a USB cable to connect to the PI? Is there any advantage to wifi other than the device becomes slightly more portable?

The Docker issues are likely caused by Docker still not supporting Buster well. You can check your service status with brewblox-ctl status. Docker issues are pretty much all or nothing: if your services are running, Docker is working.

I have no experience with using PoE with a Pi. If the Pi isn’t complaining about power supply voltage, it’ll likely work fine.

There are no features only available over Wifi. Feel free to skip the brewblox-ctl wifi part, and exclusively use USB.

Ok will try this first by using the USB as a direct connection hopefully it will resolve the pi not being able to see the controller.