Installed, but confused

I have followed the software install guide, but I’m confused as to what I should do next.

I’m able to see that there is a connection between the RPI and BPI by going into Maintainance Panel -> Device Configuration. I see None under the Installed Device, but I’m seeing my temp sensor under detected device, and it shows the same value as the LCD screen.

On the front page of the GUI the script status is constantly changing between Script Running and Script not running. When it is saying that script is running the left most fake-lcd is telling me my BPI is idle.

So what am I missing? Why isn’t the script running continuously? Why am I only seeing temp sensor data in the detected device section?

1 Like

As for the browser page’s faux LCD saying that your script is frequently switching between running and not running, that is commonly seen as a problem with Safari (both Mac and iPhone versions). Is it safe to assume you’re using Safari for hitting your RPi’s default web page? Does it work better with Firefox? I personally use Chrome on Windows and it works fine, whereas hitting the exact same page with my iPhone exhibits the on-off-on behavior every 10 seconds or so.

As for your devices, once they have been detected you have to change some settings in the various per-device dropdowns, then hit “Refresh device list” in order for your changes to take effect. Like you I started off with only detected devices and none installed, then I made the following changes in order to have them considered as Installed:

I did try to config the device like that yesterday, but I never though to use a different browser. Yester day the changes would not stick, when I hit apply and reloaded the page they were all gone.

I’ll try today with firefox.


I’ve always had the same script running/not running problem. It’s really bad under Safari, but slightly better under Firefox, Also changing the USB cable helped. I’ve just sort of got used to it now.

Also, with regard to setting up your devices, I originally followed this guide which describes how to configure your sensors and relays very clearly:

1 Like

Switched to firefox, and tried to configure a device, after I updated the BrewPI. Did some choices in the temperature sensor, see the following in the log:
evice config command sent, U:{“i”:“0”,“c”:“1”,“b”:“1”,“f”:“9”,“h”:“2”,“p”:“0”,“a”:“287F9F730600008B”}

But if I refresh the device list it reset back to the default

BTW: What hex file should I chose when updating the brewpi?

Assuming you have a Spark Core rather than an Arduino, then at the very end of the Python script ~/brewpi-tools/ you will see:

The update script can automatically check your Arduino version and program it with the latest hex file from the BrewPi server, would you like to do this now? [Y/n]:

You should answer No to this question because flashing the Spark with new firmware is done in the browser GUI instead, under “Reprogram Spark Core”.

The file to download for the purpose of reprogramming your Spark via the GUI is called brewpi.bin. As of today the preferred version to download is v0.2.7. but within a week there will be a v0.2.8 release, and potentially a new one every two weeks thereafter.

1 Like

Thanks, that got me a step in the right direction. With Firefox I got the thing updated, and it configured a temp sensor.

Also where would I look to always find the newest version?

In the LCD of the BrewPI it tells me temp i 18.7, so does the GUI LCD, but the graph beeing drawn shows the temperatur to be 22.3 should this not be the same? I got only one sensor connected at the moment.

The graph question can be ignored as the graph suddenly decided to play nice.

Now that I got the temp sensor to work, I’m looking at getting the relay to switch on and off based on the temperature. I did try to configure the Switch Actuator. If I have it inverted it is on no matter what other config I does. So if I set the temp ten degrees off from what it really is, it does not matter if I say the Switch Actuator is a cooler or a heater, it is always on. In the display on the BrewPI it only shows the temperatur and on/off the row in the middle is always blank. Any advice on what I’m doing wrong?

I can’t really say for certain, but I had problems with my relays when I first started out and it was all down to my power supply not being up to the task. I switched to a 2 Amp USB supply (Elco sells them in his shop) and that solved all my relay problems.

A powered USB hub should also do the trick if you’ve got one lying around.

The relay works fine when I use the LCD screen of the BrewPI

Do you have the relay set up as inverted by any chance?
Post a screenshot of your configuration.
The correct settings are: chamber device, not inverted, chamber cooler/heater
Uninstall all actuators you have already set up, refresh the list, then add the new one in a free slot.

I tried with both ways. When not invertet it is always off, when inverted it is always on. The settings you are giving me sounds like what I did yesterday. I’ll try it again and take screenshots, but I can’t do it before monday.

This is my config, still does not work.