Issues running install script-Github login?

I’m brand new at this, so let me know if I’m not providing the right details.

I’m trying to install the BrewPi software on my Pi, and I’m having an issue that I haven’t seen discussed elsewhere. After running the following command:

git clone ~/brewpi-tools

It returns:

cloning into ‘~brewpi-tools’…
username for ‘’:

If I type in a username, it then asks for a password, and since I don’t have either, the login fails.

I haven’t seen anywhere about needing a username or password to download the files from github, so where do I sign up for this, or what am I doing wrong?

Thanks in advance for the help.

if you go to, there you can create your account. I don’t remember it asking me for an account.

I have not seen GitHub asking for credentials either. When I just tried a clone and it doesn’t ask for a username.

GitHub only asks for a password if you are using the SSH link instead of the HTTPS link.

Ok. I created an account at github, so I’ll try again when I get home and report back. I assumed I was doing something incorrectly, but I can’t find my mistake.

Are you cutting and pasting the code into terminal on the RPI?

If you’re doing that then itd be unlikely you’ve made a mistake

Yeah, I cut and pasted. I guess I was thinking of making a mistake somewhere in the Raspian or wireless setup.

Are you pasting one line at a time or both lines together?

I seem to remember on a different command I only had success when posting a command as a chunk of them rather than one at a time.

I paste the first line:

git clone ~/brewpi-tools

And that’s when it asks for credentials. I haven’t tried pasting:

sudo ~/brewpi-tools/

Because if the initial command didn’t work, then there’s nothing to install, right?

Unless I’m supposed to be pasting them both at the same time…

That’s what I meant, not sure whether it’s fluke or not but on occasion I’ve pastes a block of command and it’s worked where I’ve experienced issues having pasted 1 or 2 lines separately.

Chances are it might not work but it’s worth a try.

i had no issues getting Brewpi to work in terms of the rpi and brewpi software so unless Elco has made a change (I’m guessing his post earlier indicates he hasn’t) it should all work ok.

You could always try and reinstall raspian and brewpi from scratch if nothing else is on it yet.