Issues with Docker clean install [solved]

I went ahead and tried to update my RPI with the new docker stuff, followed the instructions and flashed my sd-card with hypriot. I´ve got three issues, I think they might be connected.

  1. I´ve only got brewpi-data in my home-folder, no brewpi-tools… It´s supposed to be included with the docker I understand.
  2. Neither portianer nor dockerui will work, it only shows a 404 not found page at port 9000.
  3. I can’t get wifi to work… The setup of the photon via Particle app on IOS goes as planned, but the RPI cannot connect to the Photon. stderr shows either one of the two below message:
    “Could not open port socket:// [Errno 111] Connection refused”
    “Could not open port socket:// [Errno 113] No route to host”

Re-deploying the docker with USB-interface works fine though, so my beer is in good hands :slight_smile:

Any ideas what the issue(s) are?

  1. I also only have brewpi-data and everything is working fine. It is my understanding that you end up with different directories if you do the Docker install. This might be one of them.

  2. Are you looking at the list of containers at IP:9000 and trying to click on the IP link for the brewpi and portainer containers? If so, that is a known issue. You have to click on “brewpi” then click on “console”.

  3. Try unplugging the Brewpi for 30 seconds and plug it back in. I recently I had an issue with the rest of my network that seemed to cause the same messages. When I rebooted the Brewpi it came online.

  1. Yes, USB-connection is working for me as well but I would like to update the photon and the Python-script is in that folder.

  2. No, I dont Get that far, I don’t even get a login screen, only 404

  3. Yes, tried that and also rebinding with the network through the particle app.

Elco mentioned in another thread that if you installed with docker you have to update by going to the portainer interface and going to the brewpi container console and run:

cd /home/brewpi/utils

In regards to #2, do you get the 404 even when hooked up via USB too or only when using wifi?

Are you seeing your Brewpi in the list of connected devices in your router or can you ping it? What is the color/state of the light on the front of the brewpi?

The only other thing I can think of off hand is making sure the config.cfg file has the following line added and there are no errant/extra spaces in there:

port = socket://IP address:6666

/home only has one folder, “pirate”, which is the default user account on hypriot. In that folder there is only brewpi-data. I can´t find the utils anywhere.

The 404 is the reply from the RaspberryPi when browsing to it at port 9000, it is not related to the spark at all, but yes it behaves the same regardless of USB of wifi.

Starting to realise I need to update my Photon, it´s still running v0.4.3, but I don´t have the brewpi-tools…

Ok, so I´m pretty certain I need to update the photon for this to work, but the docker image does not contain the utils… @Elco how do I go about getting the utils directory?

In the latest docker image, BrewPi tools is installed in the home directory inside the container.

The container creates symlinks to the pirate users home directory to store data outside of the container so the container can be destroyed en created without losing data.

To access brewpi-tools or the /home/brewpi/utils dir, you first have to enter the container. This can be done with the portainer web interface by going to the BrewPi container and click console and connect.

Ok, managed to get portainer to work, for me to enter console in portioner I have to start the regular brewpi docker image. When I do, and run the dfu-docker it returns the below:
root@9100b99244d6:/home/brewpi# docker run -it --name brewpi-dfu --privileged -v ~/brewpi-data:/data --rm brewpi/brewpi-raspbian python util
s/ --tag=0.5.3 --noreset
bash: docker: command not found

If I run the DFU-docker in normal SSH (like the wiki page says) it returns the below:

$ docker run -it --name brewpi-dfu --privileged -v ~/brewpi-data:/data --rm brewpi/brewpi-raspbian python utils/ --tag=0.5.3 --noreset
Persistent files already present
Will try to download release '0.5.3’
dfu-util version 0.8 found installed on system.
Detecting DFU devices
Found 1 devices: [‘2b04:d006’]
Device identified as Particle Photon
Downloading release 0.5.3
tag ‘0.5.3’ not found
Traceback (most recent call last):
File “utils/”, line 264, in
binFile = releases.getBin(tag, [device_type, ‘brewpi’, ‘.bin’])
File “/home/brewpi/utils/”, line 88, in getBin
downloadUrl = self.getBinUrl(tag, wordsInFileName)
File “/home/brewpi/utils/”, line 69, in getBinUrl
AllUrls = (asset[“browser_download_url”] for asset in release[“assets”])
TypeError: ‘NoneType’ object has no attribute ‘getitem

Ok solved it… The version “0.5.3” is no longer available, changed the command line to “0.5.3-rc.2” and that solved the problem. All good now, running fine in both USB and Wifi mode :smile: