Large difference between beer set point and actual beer temperature

Does anyone know what may be causing the large temperature discrepancy between sensor and set temperature? My temperature sensor is in a small thermowell and I am not using this for brewing so it is okay that is set to below 0C. I am also using the default PID parameters.

Is this on Arduino? Looks like it from the chart.

Change your absolute minimum to -16 to allow subzero temperatures for the fridge.

It is an arduino. Do you remember where in the code this is? I do not have an option to do this in the GUI at the moment.

This can only be changed in the GUI. Do you really think that recompiling the code will be easier than installing the web interface?

Maybe you can send j:{tempSetMin: -16} over serial.

The web interface is installed and there is no option for minimum temperature setting in the Advanced Settings tab or anywhere else. I was able to this before by adjusting some of the codes, but I forget where exactly I found the variables. I should have written it down.

Are you sure you are running the legacy branch for the web interface?

That is what I installed, and I don’t think any updates have been run. Can I display the current version somewhere to double check? In the HWverision is .2.4 and the same file has my tempSetMin at -16.

It sounds like you have tried to change the minimum setting in the python script, while it is actually maintained in the Arduino.

Please run our updater:
sudo ~/brewpi-tools/ --ask

Please choose the legacy branch twice. Discard any changes you made by stashing them.

Then try again.

I reset to legacy twice and it is still not allowing the set point to go below zero. I still do not have an option to change the temperature minimum from the advanced settings.

what does it say when you run ‘git branch’ in /var/www? and in /home/brewpi?

And what about git status?

/var/www --> git branch


/home/brewpi --> git branch

/var/www --> git status

On branch legacy
Your branch is up-to-date with ‘origin/legacy’.
Untracked files:
(use “git add …” to include in what will be committed)


nothing added to commit but untracked files present (use “git add” to track)

/home/brewpi --> git status

On branch legacy
Your branch is up-to-date with ‘origin/legacy’.
Changes not staged for commit:
(use “git add …” to update what will be committed)
(use “git checkout – …” to discard changes in working directory)

modified:   settings/tempProfile.csv

Untracked files:
(use “git add …” to include in what will be committed)

no changes added to commit (use “git add” and/or “git commit -a”)

My guess is that your apache web root is pointed to /var/www/html, and you are managing the version of /var/www.

So you do have legacy checked out in /var/www/, but you are not serving the website from there.

Change the directory in your apache.conf and delete the html dir.

That fixed the minimum temperature. I may not have originally installed legacy which may have caused this, but the fix was:

Deleted var/www/html

Went to /etc/apache2/sites-available and change 0000-defaults.conf

sudo nano 0000-defaults.conf

delete html from the directory: /var/www/html --> /var/www/

from the same directory (/etc/apache2/sites-available) go to defaults-ssl.conf

again change the directory from var/www/html to var/www/

Go to /home/brewpi/settings/config.cfg

change wwwPath from /var/www/html/ to /var/www/


Thank you for your help Elco, hopefully I don’t manage to totally break this again.

After two days reading the BrewPi Community forum we still can´t get the BrewPi to work properly.
We have a brand new BrewPi (Raspberry).
The devices looks like to be configured according but BrewPi is most of the time only “Idling” . When it should to increase the temperature looks like it turns on the “Cooling”.
These are our Installed devices:

Beer Const is set to 18.0C but the LCD:

  1. Why cooling when beer it was already in 15.9C?
  2. Why idling when we want the beer to be at 18.0C and the beer is at 12.3C? Shouldn´t it start the “Heating”?

Any one had any of those problems?

Can you give more details about your setup? A chart will also explain a lot more than screenshots of the LCD display.

Thank you very much for your answer.

We gave more time to BrewPi to find the proper temperatures, and. now it’s looking much better:

But please see the beginning of the graph: beer enter at 20C, and the needed temperature was 18C. The BrewPi then place the beer temperature to less then 16C. Why? Why not keep it at 18C when it crossed this temperature?

If I look at when it is cooling at the bottom of the chart, that doesn’t explain the large drop in beer temperature.
The fridge setpoint was raised above the beer temperature before the beer was under the setpoint and it didn’t cool afterwards.

You will also get better results if you increase the dead time, so it doesn’t alternate between heating and cooling.

Thanks Elco, we were testing what you suggested and the increase in the dead time really improved the result!