Lessons learned for wifi setup


Hello everybody! Glad to be a part of the community!

So I just received my BrewPi Spark V3 last week and set in on getting everything all turned on and fired up. Fallowing the wiki tutorial, everything worked great with the Raspberry Pi part. However, when it came to getting the Spark on the wifi network, I hit several walls. I tried to use the Particle app on my Android (Note 4) phone but the app could never see the Spark. I also tried the CLI on my laptop and desktop, and they both would just hang on “attempting to configure wifi on COM13”. No matter what order I did each step I would either make things worse or hit the same conclusion. So finally after hours and hours of searching the net I found the link to the Particle site that is pretty much set up like the phone app. Particle Setup And even though at the end of the process it errored out saying I couldn’t “claim” the photon (which I have read the Spark is already claimed I guess) the Spark rebooted twice and the light finally went from blinking blue to green.

Now my fear is that since I hooked it up to my work network, I have going to have a hell of a time bringing it home and getting it set up on my home network. But we’ll see I guess. Hope this helps somebody else out.


Strange that the phone app didn’t work, did the led flash blue when you tried? Seems like you found a new method with adding to the wiki.

To make the spark forget all previously configured networks, hold the setup button for 10 seconds. It will start flashing rapidly.


Yes, every time I tried to connect, I made sure to put the Spark in “Listen Mode” first.


Elco, I didn’t see it as a topic (if I missed it I apologize) but I was wondering if I could run a VM of Raspbian on my Fedora PC so I wouldn’t even need my RPi.


You can run the ubuntu docker image:


Are there plans to develop a docker for Fedora? I would hate to have to make a Ubuntu VM just for the docker.


The ubuntu-based docker image should run fine on a Fedora host.


Yep, once I figured out how to get the docker installed on my Fedora PC, everything else went smooth. I did have to leave out the part about “timezone” in the “docker run” command. And then once it was running, open up a shell in the brewpi container and run the “tzdata” package to update the timezone. But other than that everything works great!