Lost spark-3 ip address

Hi Bob
I am in the middle of a brew and the spark has just lost its ip address, my other one is still being seen.
The spark is still running but I cannot connect to it, any ideas?
Cheers

Do you have a secondary Pi that you could use to attach USB?

I have one I could rebuild.
Do I configure as the other pi?

You only need a subset, but the easiest approach is probably to install brewblox on the second Pi. Do not start any services.

Then:

  • On the second Pi, run brewblox-ctl service remove spark-one (to make sure it doesn’t connect to the spark)
  • Connect the second Pi over USB to the Spark
  • Wipe existing Wifi credentials:
    • Hold the SETUP button until the LED blinks dark blue, then keep holding.
    • After 10 seconds, the LED rapidly blinks blue.
    • Release the SETUP button.
    • On the second Pi, run brewblox-ctl wifi.

I missed whether you tried power cycling it. What was the pattern of the LED?

When I power up
grey, flashing green, grey, blue then flashing green.

Not sure if that is the same as power cycling

That’s strange. Flashing green is connecting to wifi, which should be followed by breathing green.
Maybe it remembers two networks and tries the first, fails, then tries the second.

Can you hold the setup button and keep holding it when it starts flashing blue? It should start flashing white after a while. That clears the wifi credentials. Then set them up again. Maybe that will help.

Hi Bob,
I have one single question on updating Spark 3, can this be done through wifi, or is it still through USB. I have just been updating to BrewBlox v. 0.7.0. Everything seems to be running, but I would like to firmware update my Spark 3.
BR Ken

Wifi updates will work, unless your current version is really old.

tried running brewblox-ctl wifi a few times - didn’t want to do much. I will try building second pi this week see if that works.

Is there an eta on the pump pwm for spark 4 yet, if soon, I can just run with that.
Cheers

I think I can finish that this week, about half way on a refactor of how digital IO and PWM works.

That would be great - really looking forward to using lan rather than the wifi, which seems to drop too regularly.

Thanks for your reply

It is getting more confusing for me. I have 3 sparks (2 x spark 3 and 1 x spark 2) see ip on spark 2 & on one spark 3, but only discover single spark 3 through brewblox.

Unfortunately the only one seen is not being used - other in in fermentation - active but can’t control and herms with no ip - any ideas how I can debug?

Cheers

If you visit the Spark IP in the browser, you should get a short message telling you it’s a Spark.

Are all Sparks in the same local network?

Are the Sparks listed as active devices in your router admin page?

That’s my guess, that’s why I suggested clearing wifi credentials and setting again to ensure they only know about 1 network.


Hi Bob,
Is it right when the update writes spark-one in the header when Spark 3 is updated? The IP address is correct for my Spark 3
BR Ken

That’s the name of the service. We called it spark-one instead of spark-1 to avoid confusion, but it was not enough. In future release, adding a spark will always be a manual step and we will remove this default service for new installs.

spark-one here is just ‘my-first-spark’.

I will rebuild the wifi with different ssd and install a UPS for WAN. got an automated meter in as well as setup failover network, which seems to loose its heartbeat regularly (just what it was setup to avoid.
Once done will reset the spark 3 and see what happens. Also can you tell me how to reset the spark 2 as I am not sure which buttons are which.
Thanks in advance

The Spark 2 has the same buttons as the Spark 3 (Reset and Setup). Top right is Setup, and bottom right is Reset.

If you’re unsure, press both buttons once. The one that immediately restarts your Spark is Reset.