Network issue after updating


I just tried to update and after some point the device completely went off from connection. Trying to reconnect failed and had to pull the plug. After hard reboot, able to connect again but as soon as I launch brewblox, the device goes offline once again. I suspect something screwed in network configuration (avahi?).
Have you seen this kind of problem before?

here is the log

pi@homebrewsystem:~/brewblox $ brewblox-ctl update
INFO Updating brewblox-ctl…
INFO Updating brewblox-ctl libs…
edge: Pulling from brewblox/brewblox-ctl-lib
52b752fae230: Pull complete
Digest: sha256:a39767ffe1cfabf459e61ec25d8865c593f2e4219e6ad461f1e9e2d1a5434acc
Status: Downloaded newer image for brewblox/brewblox-ctl-lib:edge
INFO Checking Avahi config…
INFO Stopping services…
Removing network brewblox_default
WARNING: Network brewblox_default not found.
INFO Migrating configuration files…
INFO Checking .env variables…
INFO Pulling docker images…
Pulling spark-one … done
Pulling traefik … done
Pulling eventbus … done
Pulling redis … done
Pulling ui … done
Pulling history … done
Pulling influx … done
INFO Starting services…
Creating network “brewblox_default” with the default driver
Creating brewblox_redis_1 …
Creating brewblox_traefik_1 …
Creating brewblox_ui_1 …
Creating brewblox_eventbus_1 …
Creating brewblox_influx_1 …
Creating brewblox_spark-one_1 …
Creating brewblox_history_1 …
client_loop: send disconnect: Broken pipe
fdewasmes@MBP-de-Fabrice ~ % ssh pi@
ssh: connect to host port 22: Host is down

after reboot:

pi@homebrewsystem:~ $ cd brewblox
pi@homebrewsystem:~/brewblox $ brewblox-ctl up
client_loop: send disconnect: Broken pipe
fdewasmes@MBP-de-Fabrice ~ % ssh pi@
ssh: connect to host port 22: Host is down

I have posted my logs via brewblox_ctl log

looking the log, I saw an alert on the power. I tried with a more powerful power source and it’s OK now. Never seen this before. anyway :slightly_smiling_face:

Parallel startup is indeed a pretty big bump in power draw. If it happens again while using a charger of recommended specs, please let us know.
If it becomes an issue, we can add randomized delays during startup to flatten the curve, but that’s a pretty crude tool if it’s not required.

That would be a hacky workaround for some occurrences of a fundamental problem (not being able to run full load on the pi due to a shitty power supply).

I think a better idea would be to scan the logs for this warning and alert the user that he should get a better PSU.

the problem happens here and there. It appeared whenever I added a new service (node-red, chronograf for instance).
The power source I have now is very beefy. It’s a meanwell DIN transformer capable of delivering 12V 7.5A and goes to a volt adapter.
On average the PI draws 0.25A as displayed by the voltage adapter. But I guess that when a new service is added, the init of the new service may draw more power.

Official wall power adapters for the pi are 3A.
Phone chargers can usually not provide that at 5V.

that’s right. Most of the time, it outputs 2A max