New installation issues

I am trying to give Brewblox a try as I am concerned about the longevity of my Craftbeerpi setup (and its lack of development)
For hardware, I am using a Hosehead controller, to control my 2 burner system
My pi is running Debian 8.0 and is fully updated. I have been running through the Getting Started Guide and have run into an issue after the installation of Pip3
When I run the following command, I get errors:

pip3 install --user setuptools brewblox-ctl

Here is the error:
Traceback (most recent call last):
File “/usr/bin/pip3”, line 9, in
load_entry_point(‘pip==1.5.6’, ‘console_scripts’, ‘pip3’)()
File “/usr/lib/python3/dist-packages/”, line 356, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File “/usr/lib/python3/dist-packages/”, line 2476, in load_entry_point
return ep.load()
File “/usr/lib/python3/dist-packages/”, line 2190, in load
File “/usr/lib/python3/dist-packages/pip/”, line 74, in
from pip.vcs import git, mercurial, subversion, bazaar # noqa
File “/usr/lib/python3/dist-packages/pip/vcs/”, line 9, in
from import path_to_url
File “/usr/lib/python3/dist-packages/pip/”, line 25, in
from requests.compat import IncompleteRead
ImportError: cannot import name ‘IncompleteRead’

Looking at the folder structure, I do not have the BrewBlox folder at this point. Any tips you can provide would be greatly appreciated. I am a Linux newbie at best and have only learned a few things to troubleshoot etc. I have a full VNC connection to my Pi as well as SSH.

If you run pip3 install --user -U requests, and then retry, does that work?

I hope I am not screwing this up further but I keep trying stuff.

I have run your above command and then tried to get BrewBlox again. I get this message now:
pi@raspberrypi:~ $ pip3 install --user setuptools brewblox-ctl
Requirement already satisfied (use --upgrade to upgrade): setuptools in /usr/lib/python3/dist-packages
Requirement already satisfied (use --upgrade to upgrade): brewblox-ctl in ./.local/lib/python3.4/site-packages
Cleaning up…

Yea, that looks good. You can continue with the install.

Edit: Just noticed in original post you’re still on Debian 8. I really do recommend upgrading, because it’s no longer supported, and almost certainly will cause errors.

Thats the confusing part: I try to run bewblox-ctl instal and get
bash: brewblox-ctl: command not found

I also do not see a folder in /homepi/ There is no brewblox folder there.

That must be it. I am going to have to pull my controller open and put in a new SD card. I dont want to risk nuking my Craftbeerpi installation as its currently working and I cant guarentee it will stay that way if I mess around more =)
Thanks for the help Bob

1 Like

Please note that unlike Craftbeerpi, in Brewblox the control algorithms do not run on the pi. They run on our BrewPi/Brewblox Spark. The pi runs the web server, UI and data logging. The spark runs PIDs, temperature sensors, setpoints, PWM, filters, etc.
By running all low-level control on a dedicated embedded CPU, we can guarantee long term stability. We’ll keep moving more in that direction too, with a centralized server and one or more low-level control HW modules for various processes.

That is a very important distinction! I didn’t know that it HAD to have the spark. I am not opposed to getting a Spark but right now I was doing more of an exploratory session to make sure I had something that is going to continue to work. I am a bit sad that Craftbeerpi is dead. I obviously have nothing to offer the group in terms of development skills so I just need to accept that it will fail to work at one point and I will have to have a backup plan at that point.

We do offer a spark simulation. It won’t let you run hardware tests, but it lets you get a feel of the software, and what it can / can’t do.