No connection to spark


Followed instructions but not sure what or where the dump is saved. Also, still getting random issues of the spark not connecting to the service with spark now connected by usb.

When the UI is working noticed units showing °C even though I have °F selected.

The dump is uploaded by the last command. It should’ve printed a line starting with “wget…”.

If you go to the quick action editor, does it still show degC?


I did the reset and force dfu on the spark yesterday, so far its been up for 19 hours. Spoke too soon, just lost it again.

Share your EEPROM dump if you want us to look at it.



Todays log, no connection to spark. Spark is connected to the rpi by usb, and also displaying a wifi address.

Your log file seems incomplete, that’s weird.

It will not use USB, because you have --device-host= in your docker file, based on your previous complete log.

It will use that address and will not try anything else. Does that match the address displayed on your Spark?

You could try disabling ipv6 to see if that helps:

Maybe if the tilt service restarts, it causes network problems for the spark service.

Elco, pretty sure I already disabled ipv6. The ip address matches the spark, I have it as a reserved address on my router.

Could you please verify? You can do so using

cat /proc/sys/net/ipv6/conf/all/disable_ipv6

If this echoes “1”, it’s disabled.

I get a 1 in the response.

I tried your eeprom on a spark here, and the connection is stable, without a single drop.
I have no clue right now why it would not be stable at your place.

Do you see any difference when the tilt is not online?

@j616s What is the restart interval when the tilt service cannot find a connection?
Is there any mechanism to prevent very frequent restarts of the container?
We see that container restarts shortly take down the host network because it is reconfigured. I think this only happens with ipv6, but perhaps it would be good to introduce a minimal restart interval of 1 minute + some randomness. Or if a container restart is not necessary that would be even better.

I don’t think I’ve added anything for restart intervals. The container is pretty close to the template. Happy to take a look though.


I don’t have a tilt running right now. Currently running just to main fridge temp constant, don’t feel like I can trust this to run a brew session as is.

Can you try whether stopping the tilt service helps?
docker-compose stop tilt


I get the following response.
ERROR: No such service: tilt

Maybe I have the name wrong. It should match the name in your docker-compose.yml file.

There’s only the spark service in the docker-compose.yml - log always shows system services after user services, and it had started on mdns already.

The docker file here showed a tilt service, and he said he used a tilt. So I thought that a tilt service with an offline hardware tilt would cause a continuously restarting docker container, which could mess with connectivity.

Just deleted Brewblox and started over fresh. Will keep you posted.

The Tilt container doesn’t re-start if it can’t find a Tilt hydrometer. It stays up and waits asynchronously for a callback from the Bluetooth library. Sorry if I misunderstood further up. Thought you were saying you’d spotted the service failing to connect to the data store & restarting.

1 Like