No connection to spark

SOLVED The problem went away after yet another reboot of the raspi…
NOT SOLVED It came back after a couple of hours… :-/


I was using Brewblox until last week, when I bottled my last brew. I switched off my spark and fridge, the raspi continued to run. Today I wanted to use the fridge again, but brewblox won’t connect to the spark. I did not change anything in the meantime.

The spark is showing it’s assigned IP address (unchanged) and temperatures and seems to be working nicely. I can ping the spark from the raspi with low latency. It just won’t show up in brewblox.

I updated brewblox to the latest version, rebooted the pi - doesn’t help.
brewblox-ctl discover-spark does not find any devices.

It worked perfectly until I switched the spark off and on again, which is supposed to make things work, normally…

Very strange… good that it is back up. Could have been an issue with mDNS discovery.
We’ll keep an eye on it and will keep looking.

We have added an MDNS broadcast every 5 minutes from the Spark, did you wait that long?

I managed to update to the latest firmware, but now my spark is stuck in a reboot loop as described in another posting…

Yes, I waited more than five minutes, fiddling around with settings and the like… At least it felt way longer than five minutes.

Fixed, thanks for your help.

1 Like

After everything worked fine yesterday after all the intermittent firmware problems, my problem returned yesterday evening, even though I didn’t notice until now. The spark is still showing a correct IP address, a green light, the correct temperatures and setpoints, but BrewBlox shows that the service is running, but can’t get a connection to the Spark.

This might be a problem with my Raspi and my home network because it’s showing some weird behaviour lately (discovery of upnp devices is sometimes a problem), but this hasn’t ever occured with Brewblox / Brewpi before.

Could you please run brewblox-ctl log?

If uPnP also has issues, you could try setting a static IP address for your Spark.

To be safe, get the device ID by visiting the spark IP in your browser, then run

brewblox-ctl add-spark --name spark-one --force --device-id DEVICE_ID --device-host IP_ADDRESS

(Replace names in caps with values)

1 Like

Thanks, adding the spark manually works! :slight_smile:
I had already set a static IP for the Spark. (For completeness: Restarting brewblox, power cycling the spark or rebooting the Pi did not help.)

Here’s the log:

Indeed looks like mDNS device discovery (what both we and uPnP use) is acting up.

The add-spark command edits the docker-compose.yml file. If you later want to tinker with it or reset the service spec:

1 Like

I’m still having connection issues, updated and flashed spark

Was just in the basement. Spark is rebooting again.

We’re currently testing a fix for the spark crashing when it’s nearly full. Can this be said about your Spark?

Your last log truncated halfway through your block output, so I can’t use that to verify.

What do you mean by the spark being full?

Persistent memory being (almost) full. This happens at 50+ blocks or so.

Actually, no. This was a bug in RAM allocation. The out of memory handler caused a hangup of the thread manager. This is now fixed.

If you still have reboots with the latest update, can you provide an EEPROM dump so I can make an exact copy of your Spark to find the cause?
Instructions in this thread:


I’ve just removed all blocks and Brewblox and done a new install. I’ll keep you posted.



Followed instructions but not sure what or where the dump is saved. Also, still getting random issues of the spark not connecting to the service with spark now connected by usb.

When the UI is working noticed units showing °C even though I have °F selected.

The dump is uploaded by the last command. It should’ve printed a line starting with “wget…”.

If you go to the quick action editor, does it still show degC?


I did the reset and force dfu on the spark yesterday, so far its been up for 19 hours. Spoke too soon, just lost it again.

Share your EEPROM dump if you want us to look at it.