No output on digitals


#1

I just updated to 0.4.4 coming from 0.2.10 which had been working perfectly for 2 (?) years. Long story short, after my last brew I lost all networking on the RPI. So I decided that it was time to upgrade to the latest firmware and while doing so reinstall Raspbian. The upgrade went well with only one hang up while installing on the core which a restart solved. All of my devices were saved and seems to be correct.
After getting it all up and running it does not output anything on the digital pins (checked with a multimeter). So I started trouble shooting with the test mode and found that 1 & 3 work fine but 2 will not stay set to ON. Once pushed it will change to show ON for a fraction of a second and change bach to OFF.

So my question is what to look at to get digital 2 working in test and then how to get output while running a profile a or a constant temperature?

Also I noticed that i can not save changes to any of the devices. I've seen this mentioned before but haven't tried any of the numerous fixes yet.


#2

The output is going back to OFF because the PID is still running in the background. There is no hardware fault.

Please make a screenshot of your devices, then on the bottom of the advanced settings, click "Reset to factory defaults".

Then your new settings will stick.


#3

Ok I got everything reset and then added the devices back in.

After seeing in another thread that the chamber fan was no longer operational in 0.4 I believe I might have been chasing a non-issue.
Did the digital outputs change locations for Spark V1 with a recent release? My 1 is now my 3 which made it look like the cooler was not getting output and my fan was the only that would work in cooling mode. Since the chamber fan is not functional it must be that output 1 is now next to the 12v supply which is opposite of the graphic on the Spark.