Noob needs help to connect to spark


Have now updated with DFU following the updated user manual, and it worked very well.
Very well explained in the user manual.


@Elco: I have one question that is a bit outside of topic.
Is it possible to set brewpi up in a manner that makes it possible for me to connect to brewpi from anywhere?


A good way to do that is by using Teamviewer Host-edition on the Windows 10 machine you use (where Docker and the Brewpi container is installed). It installs as a service. To connect you have to install Teamviewer on the client device which you want to connect with (can be any OS). It is free for personal/non-commercial usage!

We use this setup and it works perfectly.


Thanks mate.
I’m gonna try it out rigth away :+1:


@Mathijs_Verheijen: Thank you again.
It works like hell.
That saved me from a lot of work and now I can monitor and adjust from everywhere :slight_smile:


So you’re unable to access the webserver from outside the Windows Host without the viewer? Even from a device on the same network?


I don’t believe that was their (subsequent) question. Originally, it seems like there were having trouble accessing it at all, but updating the firmware solved that problem. Subsequently, the poster asked if it was possible to access it from anywhere (which I assume meant even outside their home network), and someone suggested Windows host viewer which worked for them. I’m guessing they can access it without the viewer from other devices on the LAN.

An alternative to the host viewer (esp. for non-windows users) would be setting up a vpn server or ssh tunnel on the local network. It’s important to get security right in this case though as you don’t want anyone with free access to your local network, especially a local network with unsecured actuators controlling heating elements!


I was curious about the anywhere as well. However, I ditched my Pi and have the Brewpi server running on a Windows media server. I can access the web server on the media server but unable to access it on any other device on the same network.


Ah, in that case maybe that is what they meant. I’m not familiar with Windows media servers, but I’m guessing that for whatever reason they have the port the brewpi webserver is trying to use (80 by default) firewalled off. Figuring out how to expose that port to the local network would likely solve the problem.


So if anybody is having this issue with Docker for Windows, you have to expose tcp in Docker settings. Then you can access the Brewpi server through the host machine ip from other devices on same network.


I did not have to expose any ports in Docker. I tried Docker on Windows (surface) for a periode and teamview to connect from outside, it worked ok. The only drawback with that is if the pc reboots, then teamview makes a new kode for the connection.
I am using brewpi on Raspberry Pi 3 for the moment, and port forward to connect from outside. I am also trying to get the grip of remote desktop on RPI :slight_smile:

It was never a problem connecting on the home net :slight_smile:



I used teamviewer too, but I didn’t want to download it on every device I use to access my server. If you expose the tcp, you won’t have to use teamviewer to access the Brewpi server. You can access it just like the RPI which I was trying to reproduce on Windows.


I am not using Windows or Docker anymore. Running Brewpi on RPI now.
Startet out with Hypriot OS on RPI but could not connect to spark via wifi, so I just installed Brewpi from Andylytical’s Brewometer integration on a Jessie version of rasbian :slight_smile:

I am not very familiar on how to setup network that I can access to web server safely from anywhere :slight_smile:

Edit: Just found out how remote access RPI. Had to remove and reinstall some programs and then it worked. Now I can connect from everywhere to my RPI. :smile: