Noob needs help to connect to spark


First of all, I have to clarify that I am an absolute beginner with BrewPi, Docker and cmd programs.
Running docker on windows 10.

Where can I find the config.cfg file on my PC?
Need to edit this file to put the correct ip to the controller.

BrewPi does not find BrewPi Spark, although I have successfully set it up with the Particle App and it has got an IP address.


On the wiki, our guide says:

So in my case, the file would be in C:/Users/Elco/brewpi-data/settings/
It is possible that the file does not exist yet. Save config.cfg.example as config.cfg and edit it.

Alternatively, if you installed portainer, you can easily get to the console inside the container by going to localhost:9000 in your browser and navigate to containers–>brewpi–>console


Thanks for the quick reply.

Have tried to change config.cfg several times without it helping, but as I said, I’m completely green in this field.
I also get this error message:
Error while receiving device configuration: SyntaxError: Unexpected token C in JSON at position 0

Where in the file should I post changes?

The spark has got IP:


Your script is not running, because you have not connect the script to the spark yet. It makes sense that it cannot receive the devices then. It does need a better error message though.

Follow the instructions:


I have done that.
This is the log:


On the Spark, which version are you running? It is shown on the startup screen.
Does it show an IP address on the screen?
Is the LED breathing green?


I can not se any version no on the startup screen.
Yes it has:
Yes the LED is breathing green.
I had it going for a moment but then I lost it again :frowning:
And now I have contact again :slight_smile:



Ok, please update to 0.5.3-rc.3 for a reliable WiFi connection.
I think you’ll need to do this with DFU, as described here:

Your port setting should be:

port = socket://

There are no spaces around :. Do not change defaults.cfg


Thanks, shall do that. :slight_smile:


As I mentioned earlier, I have little experience with this, so I need to ask for a better explanation of the process for the update.

I’m confused by the content of your link.

I have installed Brewpi with Docker on a Windows 10 pc.

Should I use Docker or PuTTy to perform the commands, update with wifi or usb?
Should I perform all the steps mentioned under “Updating system firmware with DFU”?
I have tried to perform all the steps under “Updating system firmware with DFU” with Docker without success.


Problem solved, did the updating of spark from BrewPi :slight_smile:


I am sorry, I tried to do a DFU update on Windows and it turned out the process was not working and the instructions were incomplete.

A few extra steps were needed and I even needed some changes to the docker image.

Please see the wiki for updated instructions.


@Elco: just curious: Isn’t it easier for Windows users and others to use the method @Arnt used via the Brewpi web-UI (uploading the firmware via the web-UI, tab “Reprogram controller”)? Why don’t use that method instead of a relatively long DFU-procedure?

I’am trying to acquire more knowlegde on this system to prevent issues in the future…


I will continue to use the BrewPi web UI to perform this type of updates.
The process went without any problems. :smiley:
BrewPi Spark works just fine now.


The user manual for updates looks much better now, with this I think that I might have managed to get it done. :hugs:


I have just used the same procedure as @Arnt to update the firmware and it works fine via wifi!


Cool, we used the DFU method because Serial/WiFi was unreliable until recent updates.

Did you guys upload 3 files? System1, system2 and the brewpi firmware?

That should work. But we could even improve it further, so the files are downloaded automatically too.


I only download the Brewpi firmware file. Sounds like I did something ‘wrong’.

Should I reinstall everything in DFU-mode?


I did the same, downloaded the firmware (0.5.3-rc.3) from github :slight_smile:
That is what you said I had to update.
Are there more that needs updating?
I took a chance and tried out this opportunity even though I did not find any description of the procedure :joy:


Yes, the system firmware also needs to be updated. I didn’t expect it to work without that, but maybe it was updated in an earlier attempt.