Not switching to Heat Mode (SOLVED)


I’ve been having a a couple of strange issues with Brewpi. Heat Mode does not appear to switch on when the Beer Temp is lower than the set profile. I believe that I have my devices installed correctly - see screenshot below. Also, when I try to switch from Beer Profile to Beer Constant I get a message under “Status” that says Beer Mode Switch to Constant. However after a couple of seconds it reverts back to Beer Profile.

I’ve tried uninstalling and reinstalling the device but that doesn’t seem to help.
I am running a homemade Arduino setup and have been doing so for several years with no issues.

Any thoughts on what may be causing this?

Thanks for the help.

Device setup for heater:

In the Arduino version, the actuators only act on the Fridge temperature.
The PID settings change the fridge temperature setting based on the beer temperature.

Because your fridge temperature is higher than the fridge setting, your heater stays off. You should check the control algorithm page to see why.

Please note that the Arduino version has been discontinued in 2015 and is not actively developed anymore. Our new BrewBlox software replaces the BrewPi software stack, but it cannot run on the Arduino.

Thanks so much Elco, this was helpful.
I simply reloaded the defaults in the control settings and heat mode started working again. Much appreciated.

I do plan on upgrading to the Spark 3 soon!

Thanks again,