Odd SSR Behavior - shorted - AC power all the time?

Hi Elco & everyone,

My new brewpi and two SSRs order have arrived, and after study, attempted to wire up a test.
BrewPi Spark V2 and RPi are all working as advertised with latest builds. (Almost)

In test mode, with the SSRs connected to the BrewPi, I can press the Output 0 “on/off” on-screen button, and see the LED on the SSR illuminate properly. When I press the Output 1 “on/off” on-screen button, the LED on the SSR illuminates and quickly goes out. The on-screen button also toggles automatically back to “off”. If I move that SSR off of Output1 to an unassigned output, then it toggles on/off properly per button press.

Something I’ve messed up with my config? I AM in Test Mode, so would anything be overriding my testing of turning on Output 1?

Further, for that EITHER SSR, I attempted to connect 120V AC with a simple US three-prong receptacle. Ground and Neutral to the receptacle. Mains Hot to SSR Output screw 2, receptacle HOT to SSR Output screw 1. Also tried reversing the AC on the SSR output terminals even though I think I understand that direction of current flow doesn’t matter.

With the brewpi outputs connected, and AC power applied, I still get full voltage across the SSRs. It does not matter if the LED is lit or not, if the BrewPi thinks output pin is on or off. I can toggle the brewpi test button on/off and the LED on the SSRs light appropriately (if not using Output 1!!!) … but still full voltage across the output terminal at all times.

What have I missed?
Tempted to think I have two shorted SSRs, but I find that improbable, rather I’ve done something wrong…

Configuration: (is there a way to get this detail from a file?)

Device 0, slot 0 - Temp Sensor
Device 1, slot 1 - Temp Sensor

Device 2, slot 2 - PWM Actuator, not inverted, Control Pin Output 0 (A7) - Chamber cooler

Device 3, slot 3 - PWM Actuator, not inverted, Control Pin Output 1 (A6) - Chamber Heater


Apr 11 2016 18:05:56 Opening serial port
Apr 11 2016 18:05:56 Notification: Script started for beer ‘wiring_test1’
Apr 11 2016 18:06:06 Checking software version on controller…
Apr 11 2016 18:06:07 Found BrewPi v0.4.2 build 0.4.2-0-g446b226, running on a Particle Photon with a V2 shield on port /dev/ttyACM0

Apr 11 2016 18:08:13 Installed devices received: [{“a”: “28FF7E5E9015012F”, “c”: 1, “b”: 0, “d”: 0, “f”: 5, “i”: 0, “h”: 2, “j”: 0.0, “p”: 0, “t”: 1, “v”: 67.211}, {“a”: “28FF451C90150380”, “c”: 1, “b”: 1, “d”: 0, “f”: 9, “i”: 1, “h”: 2, “j”: 0.0, “p”: 0, “t”: 1, “v”: 67.102}, {“c”: 1, “b”: 0, “d”: 0, “f”: 3, “i”: 2, “h”: 1, “p”: 17, “t”: 4, “v”: 0.0, “x”: 0}, {“c”: 1, “b”: 0, “d”: 0, “f”: 2, “i”: 3, “h”: 1, “p”: 16, “t”: 4, “v”: 0.0, “x”: 0}]
Apr 11 2016 18:08:13 Available devices received: [{“c”: 1, “b”: 0, “d”: 0, “f”: 0, “i”: -1, “h”: 1, “p”: 11, “t”: 0, “x”: 0}, {“c”: 1, “b”: 0, “d”: 0, “f”: 0, “i”: -1, “h”: 1, “p”: 10, “t”: 0, “x”: 0}]
Apr 11 2016 18:09:39 controller debug message: INFO MESSAGE 12: Received new setting: mode = t

STDOUT: (lots of the following)
Apr 11 2016 18:31:50 {“BeerTemp”:66.76,“BeerSet”:null,“BeerAnn”:null,“FridgeTemp”:67.10,“FridgeSet”:null,“FridgeAnn”:null,“RoomTemp”:null,“State”:0}

What next?

There is a very small leakage current in the SSR in the OFF state. As soon as you connect a load, the voltage will drop in the off state and it will be zero.

The resistance of the SSR in the OFF state is not infinite, let’s say it is 10 MOhm.

You have this circuit:

hot --- 10 MOhm --- Measurement point 1

neutral --------- Measurement point 2

Because there is no load on measurement point 1, there will be no current. No current --> no voltage over the 10 MOhm resistor, same voltage on both sides.

Ah!!! Duh… That explains it nicely. Did I miss that somewhere in the docs? Or am I the only wanna-be electrical geek who gets all worried with a multi-meter without actually trying to plug something “real” into it for testing purposes? :slightly_smiling:

Ok, one down, one to go.
Output1 still won’t stay turned on. (the other three work fine)
What next? Please don’t say “just don’t use Output 1!” ha.

Measuring is good! This tricks many.

I think it is because you already set up some PWM actuators on the pins.

This is confusing, and I should make sure in test mode, all actuator updates and pids are disabled.
Can you check if you uninstall those, that the output does stay on?

Output 0 has a PWM actuator on the pin and it stays on in test mode… I’ll uninstall everything from Output 1 and try again. Standby

Ok, so yes. Uninstalling Device 3 on Output 1 allowed me to test it appropriately.

So, why, with Device 2 as a chamber cooler on Output0 as a PWM Actuator still allows me to test that one while configured, where as Device 3 as a chamber heater on Output1 as a PWM actuator will NOT let me test it?

Can Test Ouput1 when “uninstalled”:
Device list updated for photon with a V2 shield
Device config command sent, U:{“i”:“3”,“c”:“1”,“b”:“0”,“f”:“0”,“h”:“1”,“p”:“16”,“x”:“0”}
Parsing installed devices
Parsing available devices
Device list updated for photon with a V2 shield

Cannot Test Output1 when “installed”:
Device config command sent, U:{“i”:“3”,“c”:“1”,“b”:“0”,“f”:“2”,“h”:“1”,“p”:“16”,“x”:“0”}
Parsing installed devices
Parsing available devices
Device list updated for photon with a V2 shield

It probably is related to the PWM frequency. The heater switches on and off very frequently, while the cooler does not.

This would effect things even in “test mode”?
Seems appropriate to ignore any run-time config/requirements such as the “heater” PWM frequency if the device is in test mode.

Tonight I’ll try reconfiguring it as something other than a heater and confirm this is the issue one way or another.


I faced the same difficulties. I even switched one SSR for another. That didn’t solve the problem in test-mode.

When testing the configuration (beer probe in bucked filled with water; beer-contant mode) there was no problem, so I ignored the odd behaviour in test-mode.

Thanks… As Elco suggested, I plugged everything in and with the fridge and heater installed, things seem to be working as expected. Guess it’s just a qwirk of test mode…

I’m encountering exactly the same problem. When testing before, neither heater nor cooler could be toggled in test mode. It took me a while to understand this is probably no hardware problem and to find this thread.