One Wire SSR Expansion board with Spark 4 problem

Dear All,

I’d just changed the spark 3 with a spark 4 for my brewery. It controls SSR for heater / herms and PWM pumps. There are 3 heaters and 3 pumps. Both of the relays are 5V, provided by the Spark itself. The 3 SSR for PWM heaters are plugged to 3 GPIO modules and the fourth is dedicated to one pump relay. Every thing work very well for the heaters SSR and for the first pump. The 5v relay for the 2 others pumps are controlled by the one-wire SSR expansion board. One relay at pin A and one at pin B.

When I build the block control, once I click on “ON” for the one-wire SSR expansion board, pump is activated (I can measure 5V). But, once I click on “OFF”, the system does not commute to OFF (there is the spiral on “OFF”, the system trying to switch on “OFF” without success. It is the same problem either with Pin A and Pin B.

I’d tried reboot etc, obviously I’d controlled if wires were ok… Nothing better happens…

Some questions : 1. is the Spark 4 and the one-wire SSR expansion board are compatible ?
2. Is it just a update problem (I did not update the system).
3. Something missed ?
4. The best way would be the addition of a second GPIO module for the two pumps plugged to the one-wire SSR E.B. but I would prefer to find a mitigation before :slight_smile:

Thanks a lot for your help !


The default configuration as generated by wizards often has a Minimum ON constraint set on the Digital Actuator block. Is this active? (In the Digital Actuator block, it will show “constrained/limited by”)

Dear Bob,

Thanks for your prompt response ! :slight_smile:

I’d tried to check the constrained/limited", but nothing was activated. I’d tried to force a constrain with a minimum ON duration @ 10s, but nothing happens again…

The problem is that I am not at the brewery tonight to be sure of that :wink:



Meaning it didn’t turn on, or didn’t turn off?

The SSR boards are wired a bit strange. the outputs are a pin that is always 5V and a pin that is pulled to GND when active.
If you try to use them as a digital output with GND as reference, you can get unexpected results.

This should not affect the spinners in the UI though. Indeed check that you don’t have a constraint on the digital actuator.

Dear Elco an Bob,

Thanks a lot for the replies :+1:
I will check the digital actuators as soon as I will come back to brewery. That’s could be a way since I am not sure about constrains that are input. Keep in touch soon !

Kindest regards


Dear Elco and Bob, I get a ride at he brewery. I confirm that there is no constraint on the Digital Actuator (No constraint configured). It did not turn OFF… Guess the best way will be a second GPIO plugged at the bottom of the first one :slight_smile: I will order it soon ! Thanks a lot