One-Wire Temps Intermittent

Hello again -

Trying to get the brew system up and running, but now having issues with all of the one-wire temperature sensors. Several days ago, I ran the system on water, HLT and Mash Tun, with proper temperature controls through the Spark 4 and had only minor issues with the temperature readings.

I am running my mash pump with a 120 VAC Invertek single phase VFD to control mash flows. After having issues with the one-wire sensors, I checked the Invertek Manual to see if I had all of the grounding properly connected. I also noted that Invertek recommended installing shielded wire to the motor, which I did today. I also ran the pump drive power externally (not with the other wires). Following these changes, I ran the pumps with the Spark 4 energized. The trial was run with none of the 240 VAC heaters energized. When the mash pump is started, I immediately lose all of the one-wire temperature indications. If the pump remains in service, some of the one-wire temps will flash on and off.

I need to figure out how to stabilize my one-wire temperatures. Any help or suggestions you or anyone can provide would be appreciated. Thanks


Update: This morning I ran the VFD from an external 120 VAC source. Whaa-Laaa, the one-wire values were stable!

Now I just have to figure out if the issue is harmonics or RFI.


1 Like

VFDs can cause a lot of interference. You are not the first brewer reporting sensor dropouts when the vfd turns on.

Try to keep the cables apart from each other and perpendicular.

Thanks. I first assumed it was the motor drive wiring and switched to shielded cable following the manufacturers shield connection details. That did not help.

It appears the interference is coming from the drive supply power wiring either through EMI or Harmonics. I tried wiring the RPI and Spark power to a 240 VAC source rather than the 120 VAC source that was supplying the drive. Nada…

In order to get brewing, I wired the drive supply power to an external 120 VAC source. Not quite as “clean” but it works without issues.