OneWire Temp Sensors not seen in wizard

I’ve just upgraded to BrewBlox with a Raspberry Pi 3 and updated my BrewPi v1 Spark Core to a Photon v2. So far it all seems to be working but I cannot see any of the temperature sensors even after hitting the discover button. I’ve tried rebooting the BrewPi and RPi, checking for updates, unplugged the sensors, and plugging them in 1 at a time. These are the same OneWire sensors I used with the old BrewPi firmware.
Here is the BrewBlox log file.

You have undervoltage warnings on the pi. Are you using an official power supply?

Did you try the sensors one by one?

I was using an Amazon Basics power supply rated for 2.1A but the warning is gone after switching to the 2.4A power supply that came with the RPi 3.

Yes, I’ve tried the sensors one by one but cant get any of them to work with the new setup.

Did you get the sensors from us?
We don’t support parasitically powered sensors, because they can be unreliable. So the sensors must have their 5V pin connected.

Did you try discovering onewire devices from the spark service page?

I do believe I got the sensors from you when I ordered the BrewPi. I tried looking for the order in the store but I didn’t have a login for the current store, so I’m guessing that info is no longer available.
Discovery through the spark-one also did not work.
Here is a picture of the connector, looks like it should be getting power from the Brewpi.


Yes that looks good and like ours. I’m puzzled why it wouldn’t work. You only swapped the core for a photon, right?

Screen works and you get a beep when it starts?

Yes I only swapped the out the photon, I can get back into it and take another look for any issues.
I get 2 beeps when I plug it in and Brewblox shows on the screen and it is starting.

I dug up a Spark V1 board and tested it with the latest firmware and I also cannot see OneWire devices.

We don’t test against the V1 anymore and it seems that not many people are using it with the latest firmware because you are the first to report the issue.

Seems to be a firmware bug, so I’ll look into it and fix it so we are backwards compatible with the V1 boards again!

1 Like

Thanks Elco,
As always great customer support!
Let me know when you have something for me to test.

I rewrote the OneWire driver as part of a refactor, because the Spark 1 uses a different IC than the 2 and 3. The Spark 4 will have the same IC as the Spark 1 again.
But OneWire worked on the Spark 2, 3 and 4 with the new code. Not on my Spark 1.

It turns out that the Spark 1 board that I found in a drawer also had a hardware problem. It has been in that drawer for 5 years and I have no idea why it was there. I dug up another old board and it works, also with the current firmware.

So that makes me think it is a hardware problem after all.

Is the old Brewpi software still available so I can go back to what was working? I’ve taken apart the Brewpi again and I cant see anything damaged so in theory I should be able to return it to the old setup and still have a working system.

I cannot think of a reason for it to work on the old, but not on the new firmware, but it is a good test.
I think it must be a hardware problem.

If you flash the old firmware, the Spark should start in test mode and it will show connected sensors:

The commands below download the old firmware and mount it instead of the brewblox firmware before flashing.

docker run --privileged -it --volume $PWD/brewpi-photon-0.5.10.bin:/app/brewblox-photon.bin brewblox/firmware-flasher:edge flash

Yeah it seems dead on the sensor side, I tried the above commands and it cant see the sensor. I also put the original spark back in running 0.4.4 and it wasn’t able to see it either. Not sure what could have happened!? Starting to wish I had left it alone since it was working, bummer.

Wonder if it would be worth trying to bypass the board and wire the sensors directly to the photon? Guessing I could cut the leads and rewire to the RS485 as needed…

I’m getting +5v and GND to the RS connector so it seems like an issue with the 1-wire connection.
Testing the resistors on the board everything looks good except R3 and R4 which are both 1k (according to the print ion the board) but both
test at 2.2k

Edit: the print on the resistors are both 222 indicating 2.2K

The i2c pull up resistors at 2k2 is correct.
Most likely the DS482 is damaged. Maybe the 12V touched the onewire bus.

Wiring to the RS485 pins on the RJ12 port will not work, because that will connect them to the RS485 transiever, not to the photon.
And on top of that: any solution other than replacing the DS2482 would require custom firmware.

Ok I’m back up and running! I swapped out the DS2482 chip which fixed the sensor communication. I’d guess it was a static electricity issue when I swapped for the photon.

1 Like

Awesome. Good to hear. Didn’t know that you had the required skills to swap the SMD part, well done.

Yeah, it wasn’t that bad to swap out the component. I have access to the right equipment and one can learn just about anything on YouTube.

1 Like