OneWire Wall Mounted Temp Sensor issue

#1

I got a Spark and other items, including a wall mounted OneWire temp sensor back in February. I finally got my fridge hacked recently, and was doing a dry run - everything looked good, until I unplugged the wall mount sensor at the socket on the fermentor while doing some rearranging in the fridge; when I plugged it back in, that sensor and the chamber sensor were no longer detected by the Spark. If I just have the chamber sensor plugged in, it’s fine, I do get a reading for that one, so it seems to be an issue with the wall mounted sensor.

Is there anything I can do about it? I did manage to get the fridge hacked, but I don’t have a lot of experience with electronics/hardware.

I don’t see many posts here about problems with OneWire sensors, so I suspect this is a pretty rare situation. I did send a message to the customer support email, but haven’t heard anything and thought I would ask here as well.

#2

Sorry I missed your support inquiry.
Did you do any custom wiring for this sensor?

Also check the plastic of the RJ11 plug and inside the spark socket. If the plastic is damaged it can push to spring contacts of the socket together.

#3

No problem Elco, thanks for getting back to me.

No, no custom wiring, and I don’t see any damage to the RJ11 plug or the Spark socket

#4

Hi Elco,
I have a Onewire sensor that from time to time behave like the one Mike has. The sensor does not connect to my Spark one V2 at all, however, the sensor is connected to my Spark 3 also after updating the firmware.

#5

Can you try connecting the sensors to one port at the bottom and one at the top?
Or if you you have an RJ12 cable and extension board, first run a bit of cable and then split off the sensor?

Two sensors plugged in next to eachother can act as a dipole antenna and be extra sensitive to noise of certain frequencies.

#6

I tried connecting one at the top and one at the bottom. Same result - as soon as I plug in the wall mounted one, I no longer get a temp from the chamber sensor, and as soon as I unplug it, the Spark gets the temp from the chamber sensor.

It is a Spark V3, and I did just update to use BrewBlox last weekend, which included updating the Spark firmware.

#7

Ok, sounds like a bad sensor that needs to be replaced. Can you send your order details by email?

#8

Thanks Elco. I’ve written to your brewpi.com email address.

#9

@mdowd
I had the same issue. I twisted the cable at the sensor. Unscrew the cable and look if you put the groove and the edge at the right position.

#10

Unfortunately that’s not it - I had thought it might be, but I confirmed that it is plugged in the right way.