Particle Not working correctly

I need help. I have a spark that works perfectly, everytime. I started working on a separate particle project for my dad. I have everything installed. I am running current firmware and software. It was working yesterday morning perfectly. Last night I plugged it back in and the screen on the Brewpi had accurate temperatures, but when I logged into the web interface the script was not working and it said that it could not get the LCD data from the python script. Also all of the installed devices were gone. I have probably read hundreds of topics, but I cant find one that helps. I have tried switching out cables for ones I know that work. I have tried running updater again. Im stuck.

What are you getting in the logs?


Ok, your script is not running.I doubt that your devices are gone, there is no way of knowing when the script is not running.
It is possible that a USB cable has not been inserted well enough for the data connection, but the board is getting power.

To see running scripts:

sudo python /home/brewpi/ --status

To kill any script that has become unresponsive:

sudo python /home/brewpi/ --kill

Then wait for cron to restart it. You can check when a full mine has past by typing `date` in the terminal.

When you say you have been working on a project with your dad, is that with the same photon/core that is in BrewPi? Is it relevant to the problem you have here?

So when I type in the code to see any running scripts, no scripts are running. I think that the USB plug may be the issue as inside the female side of the plug attached to the photon the little thing inside is very loose and visibly wobbles when there is no cord attached.

I am not a fan of the USB connectors on the Photon. The quality could be better I think. It could very well be possible that it broke. Do you see it in he device manager on a PC?

The USB connection was the issue. I had ordered a second Particle to replace my Spark, and I swapped it out. It worked perfectly. No issues. I was only able to fix it this past weekend as my new house didn’t have internet to update the files until then. If you want me to send the Photon back to you, so you can check it out, I can.