Pi doesn't recognize WiFi dongle on reboot

I am having an issue with my Pi rebooting and discovering WiFi. I had to switch out my fermentation chamber for a newer model. I unplugged all of my components after powering down and then once I had completed the switch I re-attached all components and powered up. The Arduino is working great as always but my Pi isn’t configuring the WiFi. has anyone else had this problem? I will troubleshoot this week and hopefully I can figure it out. Likely it will be my friend who is a programmer and has more understanding of the code. Haha.

Does the dongle get power? Mine can take a while for it to start flashing up to 20 mins unless I unplug and put it in a different port. Mines the Edimax one that’s recommenses

I don’t think it gets power. I used a WiPi dongle and it glows blue when powered. We had to reprogram the Arduino a couple of weeks ago because of an issue with a data log name which had characters. We rebooted after fixing the issue and it powered up fine. I’m not sure why it didn’t work this time. Should I try switching the ports?

It worked for me! But mine always comes on eventually it just cAn take a long time

wifi on my pi is super touchy, sometimes i think it’s the signal strength but sometimes not. try sudo ifdown wlan0 followed by ifup. sometimes that kicks it into gear (that is of course if you can get a keyboard or an ethernet cable into it, i sometimes had to just plug the keyboard in, log in, down and up the card without seeing what im doing!)

We wrote this shell script to automate that:

It is added to /etc/cron.d/brewpi in the brewpi installer if you say yes to that prompt:

pi@brewpi ~ $ cat /etc/cron.d/brewpi
entries="brewpi wifichecker"
# entry:brewpi
* * * * * brewpi python $scriptpath/brewpi.py --checkstartuponly --dontrunfile $scriptpath/brewpi.py 1>/dev/null 2>>$stderrpath; [ $? != 0 ] && python -u $scriptpath/brewpi.py 1>$stdoutpath 2>>$stderrpath &
# entry:wifichecker
*/10 * * * * root sudo -u brewpi touch $stdoutpath $stderrpath; $scriptpath/utils/wifiChecker.sh 1>>$stdoutpath 2>>$stderrpath &

If you disabled it, you can re-enable it by removing the ~ in # entry:~wifichecker and running /home/brewpi/utils/updateCron.sh